PCI Express Root Port won't start

Hi all,

I just installed the windows technical preview 64Bit, it went smoothly.

I have this problem with the PCI Express Root Port, it just won't start (code 12).

This causes the pc to run in vgasafe mode and I can not install a graphics driver.

Odd thing is it works fine with windows 8,1 (dual boot) and 7 as well.

I tried the 32 bit version as well but seems to have the same problem.

These are the messages from the device manager:

This device cannot find enough free resources that it can use. (Code 12)

If you want to use this device, you will need to disable one of the other devices on this system.

Device PCI\VEN_1106&DEV_A208&SUBSYS_00000000&REV_00\3&267a616a&1&10 was configured.

Driver Name: pci.inf
Class Guid: {4D36E97D-E325-11CE-BFC1-08002BE10318}
Driver Date: 06/21/2006
Driver Version: 6.4.9841.0
Driver Provider: Microsoft
Driver Section: PCI_BRIDGE
Driver Rank: 0xFF2005
Matching Device Id: PCI\CC_0604&DT_4
Outranked Drivers: pci.inf:PCI\CC_0604:00FF2006
Device Updated: false

Device PCI\VEN_1106&DEV_A208&SUBSYS_00000000&REV_00\3&267a616a&1&10 had a problem starting.

Driver Name: pci.inf
Class Guid: {4D36E97D-E325-11CE-BFC1-08002BE10318}
Service: pci
Lower Filters:
Upper Filters:
Problem: 0xC
Status: 0x0

I am using the following hardware:

Mainboard:

Asrock 4CoreDual-SATA2

LGA 775 for Intel® Core™ 2 Extreme / Core™ 2 Quad / Core™ 2 Duo / Pentium® XE / Pentium® D / Pentium® Dual Core / Pentium® 4 / Celeron® / Celeron® D, supporting Quad Core Kentsfield processors     

  1. VIA® PT880 Pro/PT880 Ultra Chipsets
  2. Supports FSB1066/800/533MHz processors and H-T Technology
  3. Supports Dual Channel DDR2 667 (DDR2 x 2 DIMM slots) and DDR400 (DDR x 2 DIMM slots)
  4. Untied Overclocking : During Overclocking, FSB enjoys better margin due to fixed AGP/PCIE/ PCI Buses
  5. 1 x PCI Express Graphics slot (@ x4 mode)
  6. 1 x AGP 8X slot
  7. Hybrid Booster - Safe Overclocking Technology
  8. 2 x SATA2 3.0 Gb/s connectors, support RAID (RAID 0, RAID 1, and JBOD) and Hot Plug functions
  9. HDMI_SPDIF header, providing SPDIF audio output to HDMI VGA card, allows the system to connect HDMI Digital TV/projector/LCD devices.
  10. 10/100 Ethernet LAN
  11. Supports all features in Windows® Vista™ Premium
  12. ASRock 6CH Premium I/O: 4 ready-to-use USB 2.0 ports, High Definition Audio

CPU:

Intel E7500

Dual Core CPU

Memory:

Corsair  2x1 GB DDR2 @ 800Mhz

Graphics:

MSI Radeon HD6450 1GB DDR3 PCI Express Card

Does anyone have an idea how to resolve this?

This version of windows is using a new version of PCI.sys.

I suspect that there could be the source of the problem.

Thanks in advance

John

 

Question Info


Last updated November 21, 2019 Views 25,618 Applies to:
Answer
Answer

i have fix the problem

i changed a setting in the bios

primary graphics adapter to pci

    Open the start menu and type cmd in the search box
    Right-click on cmd.exe and select Run as administrator
    In the command window, type bcdedit /set pciexpress forcedisable
    Reboot your computer

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.