How to Unbrick a Lumia 520 in Dead Black Screen or Red Screen Bug

1. Download and Install Windows Phone Recovery Tool (now Windows Device Recovery Tool). (No need if you have already installed it.) Note: this is for the Lumia 520 only as the downloadable hex file is only intended for this phone model. Proceed at your own risk. There's no harm in trying. For Red Screen Bug, proceed to Step 15 (Check second line of Step 6 and 7 as a prerequisite to 15).

Update 12/29/2015: In Red Screen you also use WDRT if it can detect your phone. Thanks to Sanket RJ Dave for the tip. 

2. Install the following drivers just to be sure. Some of them might have already been installed with WPRT. Just cancel the installation if it’s already there. Download here.

3. If you’ve downgraded your Lumia using WPRT before it got bricked, the ffu file is already there. This is the phone installer that you need. To locate it, hit Windows Key + E then, click This PC on the navigation pane and go to C drive [mine is ACER (C:)].

4. Click View Tab then tick Hidden Items and go to ProgramData\Microsoft\Packages\Products\rm-914 and you will see the ffu file that’s more than 1 GB in file size.

5. Now, let’s create a new folder in C drive and let’s name it dump.

6. Download the hex file here (520 only)and place it in the dump folder. Next, we are going to locate the folder where WPRT is installed. Go to C:\Program Files (x86)\Microsoft Care Suite\Windows Phone Recovery Tool. Scroll down to check for thor2 as this will be needed to create 2 gpt files.

Update 12/29/2015: Download the complete hex files here and try to experiment to find the right one for your phone model (specifically Nokia only).

7. In that same folder click the File tab, then open Command Prompt as an administrator.

8. Enter the following command line: thor2 -mode ffureader -ffufile "C:\ProgramData\Microsoft\Packages\Products\rm-914\RM914_3058.50000.1425.0007_RETAIL_apac_philippines_338_07_441237_prd_signed.ffu" -dump_gpt -filedir C:\dump\ (don’t hit Enter yet)

9. Change the string name in italics using your own ffu filename in Step 4. Right-click on the ffu file, click Rename, hit Ctrl + A, Ctrl + C, then paste it after rm-914\ in the Command Prompt. Hit Enter and it will generate two gpt files in the dump folder.

10. Connect your phone to your computer using the included micro USB. In the system tray, it should be detected as QHSUSB_DLOAD.

11. Let’s flash the bootloader using the following command line: thor2 –mode emergency –hexfile C:\dump\HEX.hex –mbnfile C:\dump\GPT0.bin –orig_gpt

12. Wait for the process to finish (this will show up in the command prompt: C:\Program Files (x86)\Microsoft Care Suite\Windows Phone Recovery Tool> once it’s finished) Do not close Command Prompt window.

13. On your phone, hold Volume Down + Power and your phone should vibrate. It will boot in Red Screen. Don’t worry. That’s okay because right now you have a live phone!

14. The Black Screen thing can drain your phone’s battery in a day and it will not charge in that mode. Charge your phone for at least 1 hour because it requires a lot of battery juice when flashing the phone. Or if you have a spare Nokia 5230, you can charge the battery there since they both have the same battery type. (It’s okay to remove the battery in your Lumia phone in Red Screen.)

15. After charging, return the battery and connect the phone’s USB to your computer. Go back to Command Prompt and enter the following: thor2 -mode uefiflash -ffufile "C:\ProgramData\Microsoft\Packages\Products\rm-914\RM914_3058.50000.1425.0007_RETAIL_apac_philippines_338_07_441237_prd_signed.ffu" replacing the italicized text with your own ffu filename (see Step 4). The phone will begin flashing, wait until it successfully reaches 100%. If it fails, just remove the battery and repeat step 15.

16. Your phone will restart and should now boot in Green Screen.

17. Lastly, enter the command line: thor2 -mode rnd –bootnormalmode. If you get it right, you will get these last two lines in CMD: 

Device is already in the normal mode. (NCSd running) 

Exited with success

Your phone will reboot with the Nokia logo and it won't take long before you are directed to the Welcome screen.

PS: Thanks to all Windows Insiders who posted random solutions! It took me time to digest it all but now, I fully understand. Please forgive me if some of my terminologies are terrible or wrong. That's how I understand it and I've simplified it for you. I'm just a plain teacher and not an IT expert. ;)

You can also download the PDF version.

 

Discussion Info


Last updated February 15, 2019 Views 23,314 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello Joemar..

First of all, THNX A LOT.. After two months of struggle, i got my Lumia 525 fixed.. I doubt whether this would work, since its for Lumia 520. But it worked perfect. My lumia is now working perfectly. Even Nokia service center couldn't able to resolve the problem and MS too. Actually I was waiting for MS for a official solution. Updated WPRT v2.1.1 doesn't work out. Then, i came across ur post. I've no hope when i started the process, but at the end, i got my fav lumia got fixed. Once again thnx. I suggest other Lumia 525 users to follow this post to resolve the issue.

Great, thanks!

I have a question, I followed step by step until the 15th one, where I got stucked, now my phone is on the red screen (yipiee!), but when I write the thor2 -mode uefiflash -ffufile command the command prompr shows the following error:

C:\Program Files (x86)\Microsoft Care Suite\Windows Phone Recovery Tool>thor2 -m
ode uefiflash -ffufile "C:\Appdata\Microsoft\Packages\Products\RM-915\RM915_4058
.50000.1424.0001_RETAIL_nam_usa_228_01_439678_prd_signed.ffu"
THOR2 1.8.2.17
Built for Windows @ 12:29:55 Apr 27 2015
Thor2 is running on Windows of version 6.2
thor2 -mode uefiflash -ffufile C:\Appdata\Microsoft\Packages\Products\RM-915\RM9
15_4058.50000.1424.0001_RETAIL_nam_usa_228_01_439678_prd_signed.ffu
Process started Tue Jun 09 17:28:42 2015
Logging to file C:\Users\PAPELE~1\AppData\Local\Temp\thor2_win_20150609172842_Th
readId-1420.log
Debugging enabled for  uefiflash

Initiating FFU flash operation
WinUSB in use.
isDeviceInNcsdMode
isDeviceInNcsdMode is false
Device mode 6  Uefi mode
[THOR2_flash_state] Pre-programming operations
Disable timeouts
Get flashing parameters
Lumia Flash detected
Protocol version 1.15 Implementation version 1.28
Size of one transfer is 2363392
Size of buffer is 2359296
Number of eMMC sectors: 15155200
Platform ID of device: Nokia.MSM8227.P6036.1.2
Async protocol version: 01
Security info:
Platform secure boot enabled
Secure FFU enabled
JTAG eFuse blown
RDC not found
Authentication not done
UEFI secure boot enabled
SHK enabled
Device supports FFU protocols: 0019
[THOR2_flash_state] Device programming started
Using secure flash method
CoreProgrammer version 2015.04.09.001.
Start programming signed ffu file C:\Appdata\Microsoft\Packages\Products\RM-915\
RM915_4058.50000.1424.0001_RETAIL_nam_usa_228_01_439678_prd_signed.ffu
FfuReader version is 2015032401
Send FlashApp write parameter: 0x4d544f00
Perform handshake with UEFI...
Flash app: Protocol Version 1.15 Implementation Version 1.28
DevicePlatformInfo: Nokia.MSM8227.P6036.1.2
Unknown sub block detected. Skip...
Unknown sub block detected. Skip...
Supported protocol versions bitmap is 19
Secure FFU sync version 1 supported.
Secure FFU async version 1 supported.
Secure FFU async version 3 supported.
Get CID of the device...
Get EMMC size of the device...
Emmc size in sectors: 15155200
CID: Hynix, Size 7400 MB
Start charging...
Requested write param 0x43485247 is not supported by this flash app version.
Start charging... DONE. Status = 0
Unable to send ECHO REQ or ECHO REQ not supported
Get security Status...
Security Status:
Platform secure boot is enabled.
Secure eFUSE is enabled.
JTAG is disabled.
RDC is missing from the device.
Authentication is not done.
UEFI secure boot is enabled.
Secondary HW key exists.
Get RKH of the device...
RKH of the device is 7C81AABA97E4904DB782605A6C74A59480361E5A363337B2EF5B8F92576
3110B
Get ISSW Version...
Get ISSW Version, SKIPPED!
Get system memory size...
Size of system mem: 524288 KB
Read antitheft status...
Requested read param 0x41545250 is not supported by this flash app version.
Send backup to RAM req...
Clearing the backup GPT...SKIPPED!
Unable to parse FFU file. File open failed
programming operation failed!
Unable to parse FFU file. File open failed, Error code: 2

Operation took about 0.00 seconds.

FFU_PARSING_ERROR

THOR2 1.8.2.17 exited with error code 2228224 (0x220000)

C:\Program Files (x86)\Microsoft Care Suite\Windows Phone Recovery Tool>

----The problem is that I knowthat i selected the right bin file for the hex, now when i try to flash with that ffu file it says that its not signed for this pho, wich is Nokia lumia 520 att gophone (RM-915 059T105) hope you help me i´ve spent weeks searching for something until this page appeared, it´s all my hope. Thanks again for helping me to get in the red screen.

https://m.youtube.com/watch?v=yKVnOA1vNp4

Try the command in last few steps of the video.

https://m.youtube.com/watch?v=yKVnOA1vNp4

Try the command in last few steps of the video.

Which one, ive tried with

thor2 -mode uefiflash -ffufile "C:\ProgramData\Microsoft\Packages\Products\RM-915\RM915_3058.50000.1424.0001_RETAIL_nam_usa_228_01_439678_prd_signed.ffu"

and still the same error "0xFA001106: Signature check of FFU file fails. Reason(s): The FFU file is not correctly signed or not signed for this device."

Hope you can help me. C:

There is a notepad instructions in the OneDrive link given below the video. Download it and go to the last few steps of vpl command or vpu command.

Hi Joemar,

I followed as per the steps for L520, i got green screen, after that i executed "thor2 -mode rnd –bootnormalmode" cmd, it ended up with an error, didnt got the language selection screen. When i disconnect the phone and connect it, and execute the same cmd, debugger display connection timed out. I guess THOR2 is unable to get connection with the phone. Do I have to repeat Step15(Flashing) or any other solution is there, kindly provide me.

Thanks

Dinesh R

Can your computer detect your phone model using the WPRT? If it can, try reinstalling the software there. It might be that the installation was corrupted or you can use CMD to reinstall it manually.
Find me on twitter @joemarserrato facebook Joemar Serrato

I tried  WPRT, it downloads the package and installed it sucessfully in phone without any errors, but same problem persist when it restarts.

I tried to list connections in cmd prompt by using the command "thor2 -mode list_connections", it displays the connection only the phone displays the white NOKIA logo at initial connection to laptop, after phone changes to charging display, the above cmd does not display any active connections. The connection with the device is not existing continuously hence "thor2 -mode rnd -bootnormalmode" throws the error "connection not found". After four attempts done by thor itself it throws "THOR2_ERROR_CONNECTION_NOT_FOUND" and exits.

Thank you Joemar Serrato :) Now my Lumia 520 is working again. recovery tool is also working at 15th step.
'Aadat

please help jo... thor2 on my laptop (windows 7) always forced close... if you any idea please share with me....

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.