How to disable anti-aliasing in Windows 10 Technical Preview?

Hello,

I've been checking out the Windows 10 Technical Preview and even though I already disabled ClearType (both through the Tuner and through W8.1 Registry Edits), the fonts are still being anti-aliased in the start menu, on the Desktop and pretty much everywhere in the apps and especially in IE 11.

Is there a way to disable it completely everywhere? I am very disappointed that Microsoft doesn't make that available as a working Setting. I know that they believe that ClearType and anti-aliasing is superior, but I just can't stand to have blurry fonts on my Screen!

Thanks,

Edualc

|

Hi Edualc,

Thank you for your interest in updating to Windows 10 Technical Preview.

Glad that you tried these steps on the new Operating System and thank you for bringing it up here.

Please answer to these questions:

1. What is the make and model of the PC?

2. Which graphics card are you using?
3. What are the steps taken to make changes in the registry?


Some settings are dependent on the graphics card installed on the PC.

Eg: Using NVIDIA Control Panel
a) Select the "Desktop tile" from the Windows Start screen and then right-click the desktop to display a context menu.

b) Select "NVIDIA Control Panel" from the context menu and then click "Manage 3D Settings."

c) Click the "Global Settings" tab and then select "Off" from the Antialiasing - Mode drop-down list.

d) Click "Apply" to save the changes.  

Please reply and we will be happy to help you further.

10 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I would like an option to disable any anti aliasing as well.

I switched from IE to Chrome because my eyes cannot stand the blurryness of the anti aliased font.

--

SvenC

10 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Some settings are dependent on the graphics card installed on the PC.


Sorry, this is wrong approach. Some people don't like blurry text. This is not technical problem. This is medical - ophthalmology - problem. About 15-20% of people like me feel discomfort with blurry text. And I am developer, I see text all my working day - in Visual Studio, in browser, in text editor, in emails etc. It's awful.

Please, add setting to

"completely disable antialiasing" on text rendering level not dependent on the graphics card installed.

Moreover it will fine to have one more setting
"ignore application settings" to force rendering level to ignore antialiasing flags on API rendering functions and always show non-antialiasing non-smoothing text.

Please do that, it is possible and not so hard to implement.

PS As last resort I created special font for crisp reading

http://mbb-font.sourceforge.net/

but it doesn't work if Windows ignore antialiasing settings as it does in Modern (Metro) applications for example.

21 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I wish that option too. On Windows 7 I was able to disable anti-aliasing by some registry modification, I wonder if that would work on Win10 too.

5 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi everybody,

since other people had the same question, I wanted to contribute what I have been able to achieve (on a current version of W10, not the technical preview) since I posted this question:

1. Uncheck Turn on ClearType in Control Panel/Fonts/Adjust ClearType text

2. In the W10 Performance options, turn off the "Smooth edges of screen fonts"

3. Install the Dotum font contained in the Korean language pack (I am NOT kidding! It is one of the few fonts not smoothed by W10). Instructions are taken from this page: http://answers.microsoft.com/en-us/windows/forum/windows_10-start/some-fonts-are-missing-after-upgrade/95839dfa-0df2-4bc0-875a-fd6b57e61fe4?auth=1

  • Click the Start button.
  • In Settings, click System.
  • Click Apps & features.
  • Click on the link, Manage optional features.
  • If "Hebrew Supplemental Fonts" is not listed among the installed features, click on the "+" icon next to Add a feature.
  • Scroll to find "Korean Supplemental Fonts". Click on that item, then click on Install.
  • Click on the back arrow in the upper corner of the window.

      You should see the Korean Supplemental Fonts feature in the list as installed or in the process of being installed.

4. Create a .REG file (i.e. create a text file in Notepad and rename it, for example Font.reg)

5. Copy the following text into it (credit goes to http://www.laptopmag.com/articles/change-default-font-windows-10):


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts]
"Segoe UI (TrueType)"=""
"Segoe UI (TrueType)"=""
"Segoe UI Black (TrueType)"=""
"Segoe UI Black Italic (TrueType)"=""
"Segoe UI Bold (TrueType)"=""
"Segoe UI Bold Italic (TrueType)"=""
"Segoe UI Historic (TrueType)"=""
"Segoe UI Italic (TrueType)"=""
"Segoe UI Light (TrueType)"=""
"Segoe UI Light Italic (TrueType)"=""
"Segoe UI Semibold (TrueType)"=""
"Segoe UI Semibold Italic (TrueType)"=""
"Segoe UI Semilight (TrueType)"=""
"Segoe UI Semilight Italic (TrueType)"=""

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]
"Segoe UI"="Dotum"

6. Save the file on the Desktop, close it, doubleclick it, confirm the UAC prompt and the warning with yes to add the contents to the registry file.

7. (Optional) Use the Windows 10 DPI Fix tool (download it at http://www.majorgeeks.com/files/details/windows_10_dpi_fix.html) and set it to Windows 8.1 DPI scaling

8. (Optional) Lastly, for these being pained by IE11 font smoothing (and if you can't switch to a better browser), here is another piece of advice I found at http://superuser.com/questions/721149/is-there-a-way-to-get-rid-of-cleartype-font-smoothing-in-internet-explorer-11 (if you don't mind when certain image characters are not being displayed):

    In Tools/Internet Options/General/Fonts switch to the Dotum font
    Then go to Tools/Internet Options/General/Accessibility and check 'Ignore font styles'

The end result is not perfect, but it gets rid of most of the anti-aliasing/font smoothing effects. Where these are not disabled, the font size is increased using DPI fix to soften the strain on the eyes by lessening the blurriness of the fonts. Each method described above can of course be applied independently to achieve various effects.

 

15 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I was doing OK until I got to the "registry" -- I am a retired senior citizen and this was too much to figure out -- such as UAC?

5 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

UAC = User Account Control -> the annoying little pop-up box you receive when you try to change system settings in Windows.

Once you have created the registry file (simply a text file that you have renamed), you only have to doubleclick it and confirm the two security questions. That's it!

Oh, one last thing, you might have to restart the computer to see the effects.

Hope this helps!

Edualc

2 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated September 1, 2021 Views 53,806 Applies to: