AutoComplete not working in Edge Browser

AutoComplete not working in Edge browser although 'save form entries' is enabled. In other browsers, my email id used to popup if I enter the first letter. In edge it is not working. This makes it difficult for me to work on edge as I have to enter my email id again and again during each login. I'm currently on build 10240 and its up to date.
 

Question Info


Last updated March 10, 2019 Views 9,691 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Vasudev,

I am sorry to know that Auto-Complete is not working.

Do not worry, will assist you with the issue. 

 

I suggest you to clear the browser cache and check if it works. Please follow the below steps to know how to clear the cache.

1. Launch the browser and click on the three dots on the top right corner of the browser and you can see the settings option.

2. Under the settings, scroll down and you get an button choose what to clear under the clear browser data option.

3.Click this option and you can selectively clear the cache on your browser. You can choose from browsing history, cookies, cached files.

4. Click on clear.

If issue persists, then you need to provide feedback.

I understand your concern, Windows 10 is still in developmental stage, some options may be missing or added. I suggest you to provide feedback in the feedback app and development team may recognize your concern.

In future, if you have any issues related to Windows, do get back to us. We will be happy to assist you.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Tried clearing cache and other data. But still it does not work. I have provided feedback in the feedback app. 

Hope the issue will be rectified soon as I have migrated from Google Chrome to Microsoft Edge.

47 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My issue with Auto-Complete is using my FAVORITES in the address bar.  I am not one to scroll through favorites, folders, etc., to find a destination.  In Explorer, I've been accustomed to typing a few letters and my favorite automatically populates (or shows on an available list).  Edge gives me NONE of this.  Hope that gets corrected soon.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm moving my post from the IE11 forum to Edge:

I'm on Windows 10, Build 10240, Edge browser. Each time I go to my Hotmail account I have to type in my full email address. It wasn't like that in IE11 where I just type the first letter and there's a dropdown and I click my email address. I do have 'Save form entries' on in Advanced settings. Also, I have Autocomplete Form History unchecked in CCleaner. The autocomplete works on some sites but not on other sites (like Hotmail). This version of Windows was an upgrade from Windows 7, so all of the settings should have stayed the same. And all the usual remedies like clearing browser cache etc. don't work, we need real solutions.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is really annoying. I have to type in my FULL email address EVERY time I log in to Hotmail. And considering Hotmail/Outlook is owned by Microsoft, one would expect autocomplete to work on that website. Useless bunch of overpaid morons. Hey Satya, get your act together.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Auto complete does not work. I've tried all of your so called solutions and none of them work. When does Microsoft intend to fix this serious glitch?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Vasudev,

I am sorry to know that Auto-Complete is not working.

Do not worry, will assist you with the issue. 

 

I suggest you to clear the browser cache and check if it works. Please follow the below steps to know how to clear the cache.

1. Launch the browser and click on the three dots on the top right corner of the browser and you can see the settings option.

2. Under the settings, scroll down and you get an button choose what to clear under the clear browser data option.

3.Click this option and you can selectively clear the cache on your browser. You can choose from browsing history, cookies, cached files.

4. Click on clear.

If issue persists, then you need to provide feedback.

I understand your concern, Windows 10 is still in developmental stage, some options may be missing or added. I suggest you to provide feedback in the feedback app and development team may recognize your concern.

In future, if you have any issues related to Windows, do get back to us. We will be happy to assist you.

None of the steps you suggested work. I even rebooted several times. Microsoft Edge auto complete still doesn't function. When does Microsoft plan to fix this problem as I have not seen anything definitive adequately addressing this vexing issue.? Does anyone have any other ideas? I do not use a proxy server making another suggested fix useless. Are there many others experiencing this annoying problem? If so, then Microsoft should do something about it rather quickly. Furthermore, auto complete in Microsoft Edge should have been thoroughly tested under numerous scenarios and conditions prior to release. I believe Microsoft has some serious explaining to do here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

They'll probably say it is a security enhancement. These "support engineers" are really pathetic.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've followed the directions above and still no autocomplete in edge

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Do what I did - use IE11 instead of Edge. See my post under "Can't add google toolbar....."

http://answers.microsoft.com/en-us/windows/forum/apps_windows_10-msedge/cant-add-google-toolbar-in-microsoft-edge-windows/e8169410-33e7-4760-aaa2-b458d97ae858?page=6

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.