Playing .m3u files - no longer play, displays this message instead: Internet Explorer cannot display the webpage

With IE9, my .m3u files no longer play. The content type is "audio/x-mpegurl". What do I need to do, to activate playing of these files again?

 

I suspect that IE8 used the file extension to select a player, as the desktop explorer does.

 

My suspicion about IE8 player selection appears to be wrong. My resolution, in September 19 response, was relating to Windows Media Player.

Hi,

 

  • What is the error message you encounter?
  • Are you trying to play this file online or from the computer?
  • Does the issue appear on specific website or on all web-sites?
  • Can you play the .m3u files types using Windows media player?

 

You can try the following methods:

Method 1:

 

You can check in Internet options if "play sound in webpages option is selected"

Internet options>Advanced>multimedia>play sound in webpages

 

Method 2:

Check if it works in the compatibility mode. Some websites may not display the webpage correctly or work as expected due to the compatibility issue.

 

  1. Close all except one Internet Explorer window.
  2. Click Tools, and then click Compatibility View.
  3. If Compatibility View is not enabled, click Compatibility View Settings.
  4. Under Add this website, type the website that you are trying to visit and then click Add.
  5. Click Close.
  6. Restart Internet Explorer.
  7. Try to browse to the website.

 

You can also refer the link: http://windows.microsoft.com/en-US/internet-explorer/products/ie-9/features/compatibility-view

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

To answer your questions:

    The error message is:

        Internet Explorer cannot display the webpage

    I am trying to play the file online.

    It seems to be for all websites that have .m3u files as links.

    I can play it from the media player.

 

Method 1:

    Play sound in webpages was already enabled.

 

Method 2:

   I alrady have the site in the list.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey Greg027,

 

What played the .m3u files when you were using Internet Explorer 8?

 

Let's check to see if an add-on has been disabled that was being used before to play the files. You can check this by:

  • Open Internet Explorer
  • Click Tools
  • Click Manage add-ons
  • Under Show:, click All add-ons
  • Identify the add-on that was being used in the right column and select it
  • Click Enable
  • Click Close
  • Close Internet Explorer
  • Open Internet Explorer

 

Look forward to hearing back from you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Steven,

 

I use Microsoft Media Player. It is/was an enabled Add-on.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Steven,

 

I use Microsoft Media Player. It is/was an enabled Add-on.

 


Hi Steven,

I am also having the same problem as Greg027.

Using windows 7 ultimate, IE9 and MS Media player.

The error I get is "Oops! Internet Explorere could not connect to......."

I have also checked that the add on is enabled, and it is.

I do not get the compatibility option under tools.

I am also trying to play the file online.

I get this error message on all webpages that have a streaming option with a m3u file.

 

Thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have not found a resolution yet. Although I assume that it is not a widespread problem, because the page I have problems with is one that I maintain, and no on else has reported this issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Kevin,

 

I think I stumbled on to an answer for my situation.

 

In my case the problem apparently was not Internet Explorer. Rather it was Media Player.

Media Player functioned from the Windows Explorer, but not from Internet Explorer.

 

The command:

RegSvr32.exe wmp.dll

seems to have corrected my issue linking IE and Media Player together.

 

I ran the command from a Windows Command Prompt, elevated to admin. However, I do not know that the admin rights were required.

 

If you still have the issue, hopeully this will help.

 

Greg

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated May 16, 2018 Views 1,571 Applies to:

Related Forums