Internet Explorer Security Certificate Error

I keep getting error messages that says Internet Explorer blocked this website from displaying content with security certificate errors.

Oddly enough it happens when I go to the Bing.com web page, however it happens with others also and is very annoying. Bing's security certificates can't have security errors.

 

I've check the clock and date setting and they are correct. I've tried rebooting, problem persists.

All updates up to yesterday's MS updates 6/12/2012 reflect installed correctly.

Running Windows 7 64 bit, using IE9 64 bit browser.

Help!

 

Thanks!

 

 

Answer
Answer

Hi Skier7667,

 

Method 1-

 

You need you need to perform the steps mentioned below to reset web security settings-

a) Open Internet Explorer and click on “Tools”.
b) Now select “Internet Options” and select the “Security” tab.
c) Now select “Custom level” and then select the “Reset” tab at the bottom.
d) Click on “Apply” and then “Ok”.

 


Method 2-

 

I would have you install the root certificate update from the article mentioned below-

Update for Root Certificates [March 2011] (KB931125)
http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=6149

 


Hope this helps!!!

 

85 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated March 22, 2020 Views 129,636 Applies to:

Related Forums