Internet Explorer 9 won't display some websites correctly, even with compatibility view.

I recently installed IE9, first the RC version and then I upgraded to the release version. My personal website did not display correctly, and a message popped up stating that some a problem displaying the website has caused IE to refresh the page in compatibility view. However, even in compatibility view, the page is missing most of its content. It worked fine when I had IE8 installed. If I use Developer Tools to switch to any browser mode other than IE9 Compatibility, the website completely stops responding or changes to a black screen.

I thought it might be just my site, but browsing around the internet for solutions, I ran into others, including http://w3.org and http://social.msdn.microsoft.com/Forums/. Both of those websites either won't display at all or will display in compatibility mode with most content missing, or will freeze.

I have tried switching between hardware and software acceleration but neither way seems to make a difference. And I get the same results whether I use the 32 or 64 bit versions of IE. I'm sure it's something to do with my computer but I can't find any plugins that were causing it and I'm out of ideas. Can anyone help?
 

Question Info


Last updated October 17, 2018 Views 39,869 Applies to:
Answer
There is a bug that causes massive display issues in IE9 if you have Helvetica installed. It will cause display problems on sites that declare Helvetica as the first font (in their CSS). Have you explored this as the source of the problem?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.