IE9 always rendering pages in IE7 compatibility mode

I have IE9 installed on a 32 bits Windows 7 machine at work.
Every time I open a website it is rendered in IE7 compatibility view. Also the user agent of IE 9 is appearing as IE7.
To make things worse there's no option to disable compatibility view and the compatibility view icon doesn't appear at the address bar either.
I discovered that if I open Developer Tools, I can switch to IE9 mode, but it will only work for that tab and when reopened IE7 compatibility view will be default again.
Does anyone knows how to fix this? This behavior is happening since the beta. I thought it would be gone in the stable version but it doesn't.
 

Question Info


Last updated May 12, 2019 Views 68,829 Applies to:
Answer
Answer

Hi,

Step 1: Let’s turn off compatibility view and check.

a.     Open internet explorer.

b.     Click on Alt key on the keyboard. Now click on Tools in menu bar.

c.     Select Compatibility View Settings.

d.     Remove the check mark for Display all websites in Compatibility View and close the Compatibility View Settings window.

Step 2: Reset internet explorer settings and check.

Refer: http://support.microsoft.com/kb/923737 (This article may also be used for internet explorer 9)

 

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.