Question

Q: i have been noticing high cpu usage when using internet explorer that has not been a problem until a couple weeks ago This thread is locked from future replies

a couple weeks ago i started getting performance alerts that says i have high cpu usage by internet explorer... it is causing my computer to slow way down or stop completely... i have not added any software, hardware, or changed any settings prior to seeing the alerts. i have always backed up my computer, run regular scans, run disk clean up and defrag regularly, and always scan files that i get from others either through email, facebook, or sharing of pictures. the only threats i have run into have been a couple of tracking cookies. i have been told that running a computer at 100% cpu usage is very bad for it. all of the scans, and performance monitors i have tell me that i need to upgrade my cpu and ram... but why now all of a sudden? and why has it always ran fine before? please help

Answer

A:

should i limit my use of the computer until i figure out the problem


Hi,

I think you're too worried about these spikes. The occasional spike in CPU usage won't damage the computer.

Your display settings may be adding to CPU usage.
Look for "Turn off visual effects" here
Optimize Windows 7 for better performance:
http://windows.microsoft.com/en-us/windows7/Optimize-Windows-7-for-better-performance

Process Monitor http://technet.microsoft.com/en-us/sysinternals/bb896645  may help you identify the process that's causing this.

Don

Did this solve your problem?

Sorry this didn't help.



 
Question Info

Views: 43,053 Last updated: March 31, 2018 Applies to: