How do I tell IE9 to always open a certain filetype without asking me first?

Whenever I click on a link to a file in IE9, a prompt appears at the bottom of the screen that says "Do you want to open or save (filename) from (website)?", with the options to "open", "save" or "cancel".

How do I configure IE9 to automatically open a specific filetype without prompting me like this? In previous versions of IE there was an option to "always do X", rather than having to click "open" every single time.

 UPDATE:

Amazingly, after eight months there is still no clear solution to this simple problem. Because of this, I have now stopped using Internet Explorer and have completely switched over to Google Chrome. The first time I tried to download a file I told Chrome to "always open" that file type. Boom - done. No problems, inconsistencies, registry edits or other hassles. Goodbye IE! Hello much superior browser, Chrome!

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I think I have your anwser. I had the same problem with opening PDF files via IE9. Here is what worked for me...

http://social.technet.microsoft.com/Forums/lv/ieitprocurrentver/thread/57402307-1cbd-49db-aabd-65c2fea19ed9

Basically, you go to the registry key...

HKCU\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046}

...(create this key if it doesn't exist) and add a zero-byte REG_DWORD value under it named appropriately for the file type you want to open. Like this...

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046}]
"AcroPDF.PDF.1"=dword:00000000

The tricky part is determining the proper name to give to this registry value. You need to look at the key names under HKCR and maybe try different ones associated with the file type you want to open. But once you get it, it works. In the case of PDF files (with Adobe Reader) it's AcroPDF.PDF.1, for example.

I plan to distribute this reg value via group policy to all my users who are complaining about being prompted to open/save PDF files from our accounting web site.

Good luck!

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You, sir win the prize! This is what works, first time, every time.

It takes some work, identifying the file types, but it DOES let them open ever after without nannying us to death.

I appreciate your sleuthing, and your sharing both the steps and your source.

I hope others plagued with this issue add their Yes votes to propel this to the top of the list where it belongs.

Thank you for bringing a long journey of non-discovery and frustration to an end.

Best of luck in all your endeavors!!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the effusive reply, ghSea! Your frustration resonated with me, so I'm glad that you discovered my post so quickly and that you found it helpful. Best to you, too!

-gp

 

P.S.: I enjoyed reading your posts! You have flair.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Download a file with the extension you always want to open. Press Ctrl-J, then right click the file type you want to always open, then uncheck "Always ask before opening this type of file". IE9 will always open files with that extension.


I have users who try to do this but find that the "Always ask before opening this type of file" entry isn't even available to check or uncheck.  What then?

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Reference: http://support.microsoft.com/kb/2678934

See if this helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

I've tried the fix for DOCX Files, this works fine but in the case of PDF Files (AcroExch.Document) I still get the prompt - Why isn't this working MS?!

 

Thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This thread's been very helpful to me, and I've been able to use the information in it to suppress the initial prompt when trying to open a Word document from our corporate network, but I'm still receiving a prompt at the bottom of the screen, asking users to save the document.

We run an in-house developed case management application, that runs in in Java through the browser.  Via Word, documents are uploaded into the database running the application, and users can also retrieve and view documents through the application, using a View Doc button.

Now I can avoid the initial prompt for Word docs and PDF files, but when a Word document is opened, the yellow prompt still appears down the bottom of the window - 'Do you want to save [document name] (26kb) from [local server name]?,  I have the option to Save or Save As, but not Save and Open.

Is there a way I can avoid this prompt, and have the document open directly without prompting?  I don't want users to save these files locally - they should be able to open them, edit them, and then use their custom upload function to get them back into the database.

The address they're opening them from is in the trusted zone, with a low security setting.  I just can't figure out how to get rid of this prompt.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ok - I have this problem and the fix above worked for .docx and .tif files, but not for .rtf files.

In IE9 download manager if I right click on the testfile.rtf, the "Always ask before opening.." is there and unticked, and if I check HKCU\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046} there is a zero length REG_NONE value for Word.RTF.8, but I still get prompted for Open, Save, Save As.

Anyone got a fix for RTF files?

 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This worked for me.  Thanks!

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Does anyone know if the reg fix described here also applies in IE10? We have lots of user complaining about this problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 9, 2020 Views 68,561 Applies to:

Related Forums