Cannot view .png pages in Internet Explorer

I cannot view .png pages in Internet Explorer. I think this problem ends up sounding sort of weird when other people, or I write it out. It's hard to explain what exactly the problem is. People who answer the question think that we want to change the PNG file associations to Windows Explorer or something.

So I will try to make it clear:

This is not a problem with the file type associations in Control Panel. It is not fixed by going into "Control Panel > Programs > Default Programs > Set Default Programs", or by going into "Control Panel > Programs > Default Programs > Set Associations", and it is not fixed by disabling add-ons in Windows Explorer.  I do not want Internet Explorer to be the default program associated PNG files. PNG files are associated with Paint on my computer, and that's how I want them to stay. All I want is to be able to view .png webpages in Internet Explorer.

 

Again, the problem is that I can't view .png pages while on Internet Explorer. I can view PNG images if they are on a webpage. But if I click on a link that leads to PNG image (for example: http://www.website.com/pictures/image.png), then a window opens up asking "What do you want to do with image.png?" with options "Open - The file won't be saved automatically.", "Save", or "Save as". This, of course, opens the image in MS Paint, rather than taking me to the page in Internet Explorer. I don't have this problem with JPG files. If I click on a link that leads me to a JPG image (for example: http://www.website.com/pictures/image.jpg), then I can access a webpage within Internet Explorer, with the image aligned to left side, and the ability to enlarge the size, and so on. I have been able to do this with PNG files in the past. I don't know what's gone wrong.

 

HISTORY:

I first noticed the problem when I clicked on a link to a PNG image, but the file association within IE was Quicktime. I could get to the .png page in IE, but the image was centered in the middle of the window, and it was stuck in a "fit to screen" setting, so that I couldn't enlarge it, even though I had viewed the image in the past, and I knew it to be much, much larger. In other cases, .png pages simply failed to load, showing the "Broken" Quicktime image. I tried fix the issue by using these two options in Control Panel: "Control Panel > Programs > Default Programs > Set Default Programs", and "Control Panel > Programs > Default Programs > Set Associations", but in both cases, PNG files were associated with Paint, which was what I wanted. I tried to disable the Quicktime add-on, but when I did that and tried to go to the .png page, all I would get was a small box with a red "X" in it (a broken image link, or whatever it's called). So uninstalled Quicktime entirely.

Now IE won't even let me view .png pages, I am simply prompted to download the images.

 

Please help me fix this here. I don't think this has to do with Quicktime, or if it does, I don't think any Apple help sites will help me. They don't understand why you would ever use Internet Explorer or a PC or anything, and they always say it's the PC's fault, and definitely could not be an issue caused by Apple software. I need help here!

 

Thank you for reading my long explanation! I hope I made my issue very clear so it is easier to answer. I am frankly stumped.

You already rock for reading this far!

 

EDIT: I have noticed that sometimes PNG images take a longer time to display as a webpage is loading.

 

EDIT 2:  The problem is fixed if I turn on Compatibility View. Compatibility View fixes the problem whether QuickTime is installed or not. However, since this problem happens on all websites I have visited (and has not happened in the past with IE9), and since Compatibility View has many drawbacks, my problem isn't solved. But I hope this helps give a clue to the cause.

 

Question Info


Last updated October 23, 2018 Views 16,068 Applies to:

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Wild guess...

I would reinstall Quick Time then open Quick Time Player> Edit> Preferences> Quick Time Preferences> Browser> File Types (do the same with Mime Settings.) Uncheck all file types (except maybe qt, qti, qtif) and OK your way out.

 

Uninstall QT again if you wish, but with no (or almost no) file types associated with it, it shouldn't cause trouble.

 

Don

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

But like I said in my explanation, PNG images are displayed on websites in Internet Explorer, but I can't access the URL of PNG images. So I can't view pages that end in ".png" in Internet Explorer. Every time I click on a link that leads me to a URL ending in ".png," I am prompted to download (or "Save") or "Open" the image in MS Paint. These are images that I know I can access normally from Internet Explorer on other computers.

So, PNG images are displayed on websites in Internet Explorer, but I can't access the URL of PNG images, which end ".png".

 

@Don Varnau

I forgot to mention that I did try exactly that in QuickTime before I uninstalled it, but it didn't work.

Should I try the "PNG_fix" recommended in avg292's answer?

I don't know if it really addresses my problem, since PNG images being displayed on websites was never the issue.

I'm worried that any unnecessary changes to registry files might cause worse problems than the one I'm trying to fix.  

EDIT: But I've noticed that sometimes PNG images take longer to appear on a webpage as the page is loading, especially if there are a lot of them. However, the delay is usually only 1-2 seconds.

EDIT 2: The problem is fixed if I turn on Compatibility View. Compatibility View fixes the problem whether QuickTime is installed or not. However, since this problem happens on all websites I have visited (and has not happened in the past with IE9), and since Compatibility View has many drawbacks, my problem isn't solved. But I hope this helps give a clue to the cause.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This has nothing to do with Quicktime. This is an inherent "feature" of Internet Explorer.
I have used versions 8, 9 and 11 to test this with.

The issue is that if we click on a link, say http://i.msdn.microsoft.com/dynimg/IC496486.png then IE will prompt me to download the file or open it in something else. It will not simply display the image in a tab.

However, if I use Chrome or Firefox and click on that same link, I will be met with a new tab containing that image and only that image.

There is no reason what so ever that Internet Explorer cannot participate with normal expected behaviors, except that this is implemented by design.

If there is no fix for this, then the IE team needs to create a patch that will allow Internet Explorer to do so.

And Don, I absolutely love how you automatically assumed it was the other guy's fault.

I do not recall this actually being an issue until recently. Perhaps there was a patch that prompted this behavior. Either way, I'm through with using Internet Explorer at all. I will be switching to Chrome or Safari as my secondary browser, as I've been using Firefox as my primary browser for quite a while.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

1. And Don, I absolutely love how you automatically assumed it was the other guy's fault.


 

This has nothing to do with Quicktime. This is an inherent "feature" of Internet Explorer.
I have used versions 8, 9 and 11 to test this with.

2. The issue is that if we click on a link, say http://i.msdn.microsoft.com/dynimg/IC496486.png then IE will prompt me to download the file or open it in something else. It will not simply display the image in a tab. 

1. What "other guy?" It sounded, to me, at the time (12.5 months ago) that QuickTime might be the culprit. I've had QT hijack file associations on my computers.

 

2. I've hit that link today with IE8, IE9, IE10 and IE11 without issue. PNG files on those computers/partitions are associated with IrfanView (2), Paint and Windows Photo Viewer.

 

> This is an inherent "feature" of Internet Explorer.
I have used versions 8, 9 and 11 to test this with.

 

I don't remember whether or not I had the problem with IE 5.5 or IE6, but have not had it with IE7 or newer. But, back in the IE5, 5.5, 6 era, PNG images were much less common.

 

The REG files at

http://www.winhelponline.com/articles/202/1/PNG-images-are-not-displayed-on-Web-sites-in-Internet-Explorer.html

(posted by avg292) have helped many users running XP or Vista. I don't know if the files are safe or effective with Windows 7.

 

Don

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I hate to bump an old thread, but if you want to see if the png will display correctly without compatibility view you could write some very simple html code. Type this into notepad:

<html>

<head>

<title>Here's a png</title>

</head>

<body>

<img src = "mypng.png" />

</body>

</html>

where mypng.png is the filename of your png, and you save this text from notepad as something.htm (NOT .txt!) into the same folder as your png. Now you can open the webpage you just created with internet explorer or edit it with notepad to change the image it references.

Your png should avoid the "Do you want to download?" check using this method.

Another option would be to go into Internet Options, and change what the default action is when downloading a png. I use Firefox so I can't tell you were to find this. Both of these methods do not involved Compatibility View.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the exact same problem reported by this user.  A URL that I open which leads to a PNG file (not a PNG file contained in another page, but just a PNG file as the result of a URL) causes IE to display a download box, and ask me to save the file and open it using something other than IE, even though IE would normally be perfectly capable of displaying the image, just as it would for a GIF or JPG URL.

After some experimenting, I noticed something even more odd.  If I already have IE open, and I choose to open a URL that leads to a PNG, IE opens a new tab and displays the PNG file just fine!

The PNG download dialog is only displayed if IE was not running, and is launched to display a PNG URL.  If IE was already running, the PNG URL is displayed without any trouble at all in a new tab.

Can anyone else replicate this problem?  I'd like to know how to fix it, too.  It's quite annoying when a friend sends me an IM link that happens to go to a PNG image, and I have to go through extra steps to just look at the picture.

Windows 8.1

Internet Explorer 11.0.9600.17842

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.