Slow internet connection.

Have AT&T service.wireless service via 5530 HSPA mini card modem (Installed at Factory Dell) Computer orginally have Vista Ultimate installed with Windows 7 upgrade. After I up graded to 7 internt connection is via Internet Explorer 8. Connection via ? IPv4 nothing on IPv6. Is there something about this connection that slows down speed? Wifi connnection has not worked (link 5300 AGN modem) both have excellent signal strength. Computer is running Macfee sercurity and is used at home Can anyone help slow and lost..  
Question Info

Last updated May 16, 2018 Views 481 Applies to:

Hi Izzy,


First I would suggest you to try to put both the computer in clean boot state to make sure that and third party applications are not causing this issue and check if everything works fine.

To perform a clean boot, follow the steps below:
1. Click Start, type msconfig in the Start Search box, and then press ENTER.
 If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
2. On the General tab, click Selective Startup.
3. Under Selective Startup, click to clear the Load Startup Items check box.
4. Click the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable All.
5. Click OK.
6. When you are prompted, click Restart.
7. After the computer starts, check if the internet speed is fine.


If your issue is resolved after performing Clean Boot  then follow the steps mentioned in the following KB article to narrow down the exact source:
Also, see the section on how return your computer to a Normal startup mode by following the steps under “Reset the computer to start as usual”.

Since you have mentioned that you have Mcafee installed on your computer, you may try to temporarily disable Mcafee on your computer and check if the Internet speed is good. If the issue is fixed by disabling Mcafee I would suggest you to contact Mcafee support to check if there is any setting that needs to be changed and also re-enable Mcafee after checking with the issue.


Hope this helps. Let us know the results.


Thanks and Regards,


Srinivas R Microsoft Support.

Visit our Microsoft Answers Feedback Forum and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.