Embedded iwebbrowser2 does not support Java

Hello,

I have created an embedded web browser control (using iwebbrowser2) and I have a problem: It doesn't seem to be able to load java. I also tried loading http://www.javatester.org/version.html , but no version is shown. However, the standalone IE shows it allright.

From what I understand, this is caused by the fact that, unlike standalone IE, iwebbrowser2 still tries to use Microsoft JVM, which is no longer in use since the times of XP.

I tried the Java workaround of adding JAVA_PLUGIN_WEBCONTROL_ENABLE = TRUE to the environment variables, but it doesn't help at all.

I have Vista with IE8, but the same thing happens an all WinOS >= XP and all IE >= v.6


Thank you!
 

Question Info


Last updated May 17, 2018 Views 681 Applies to:
Answer


Hello
Welcome to Microsoft answers

The issue you posted would be better suited in the MSDN community. Please visit the link below to find a community that will offer the best support.
http://social.msdn.microsoft.com/Forums/en-US/iewebdevelopment/threads

Hope it helps
Thanks and regards
Dinesh-Microsoft Support
Visit our Microsoft Answers Feedback Forum and let us know what you think
http://social.answers.microsoft.com/Forums/en-US/answersfeedback/threads/

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.