Q: Unable to enable JavaScript in IE8 This thread is locked from future replies

I'm unable to enable JAVASCRIPT in INTERNET EXPLORER 8.
I've tried many suggestions from blogs without any
success.  It's fustrating!  I've been using FIREFOX,
if I need JAVASCRIPT.  The response is always 
'JAVASCRIPT needs to be enabled in your browser'.  



I have ie8 and this worked for me. Maybe it will for you too.  Good luck.

  1. Start Internet Explorer.
  2. On the Tools menu, click Internet Options.
  3. On the Advanced tab, click Reset.
  4. In the Reset Internet Explorer Settings dialog box, click Reset to confirm.

This worked for me, too!  Thanks so much!  Possibly, just disabling add-ons might have worked.  But this was fine by me.  I highly recommend trying it.

In my case, the problems caused were minimal, but it was clear that in some places where active scripting was being used in Web pages, the entire page didn't display, or the IE 8 (on Vista) window would be empty.  For instance, the arrow and zoom controls on Google Maps were just white blank spots, and when I tried to open any courses in the Microsoft Learning Viewer on, the Learning Viewer would never fully load its content.  I even put in a ticket to Microsoft but cancelled it just now (they hadn't made any suggestions yet), since resetting IE's settings did the trick.

About a year ago, I also had an issue where a lot of other scripts weren't working properly--YouTube videos, for instance, were replaced with a message saying "Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player," as we've seen from others posting here; and Google Maps would load nothing on the page where the map should have appeared.  Adobe Flash Player's download area would never prompt me to download...but uninstalling and reinstalling Flash Player, Shockwave Player, and Java in various ways didn't do a thing.

In that case, what finally fixed it was running the command prompt as administrator (by right-clicking Command Prompt from the Start Menu and selecting "Run as Administrator" while logged into an administrator account on the computer) and then doing the following, hitting enter in between lines:

cd windows\system32
regsvr32 /u jscript.dll
regsvr32 /u vbscript.dll
regsvr32 jscript.dll
regsvr32 vbcript.dll

If anyone wants to try this and then reboot, it may solve your problem.  And it won't hurt if it doesn't help.

Good luck!

Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply



This works for me!
Taken from google groups forum...

"Also, if you're having a problem in your browser with JavaScript, you may
want to re-register the jscript.dll file. This can be done by executing the

Start > Run...
In the Run box, type in (without quotes) "regsvr32 jscript.dll"
You should receive a popup says that it registration succeeded.

You then should be able to display JavaScript in your browser properly.

John J.
MCP, MCDST, MCTS: Vista Config, MCITP: Vista Enterpris"

Did this solve your problem?

Sorry this didn't help.

Question Info

Views: 396,193 Last updated: February 23, 2018 Applies to: