"sorry, add-ons can only be installed for ie8 and ie9"

I have a user who cannot add a search provider to his browser.  The message "sorry, add-ons can only be installed for ie8 and ie9" is displayed.  The system has Vista and he has IE version 8.0.6001.19019.  It seems to be profile specific as another user can add search providers on the same computer.  Today we have 2 more users with the same problem.  We have ruled out compatibility mode.  Tested that by removing the check from Display all websites in compatibility mode.   Help please

 

Question Info


Last updated May 16, 2018 Views 1,509 Applies to:

The message "sorry, add-ons can only be installed for ie8 and ie9" is displayed.


This sounds like a User-Agent problem.   Compatibility mode is only useful if the UAS is not corrupt.  E.g. all it does is substitute  MSIE 7.0  for  MSIE 8.0  in whatever the rest of your UAS is.   You can try using  UAPick  to fix up what you have or to spoof something else.


Good luck
Robert Aldwinckle
---

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The message "sorry, add-ons can only be installed for ie8 and ie9" is displayed.


This sounds like a User-Agent problem.   Compatibility mode is only useful if the UAS is not corrupt.  E.g. all it does is substitute  MSIE 7.0  for  MSIE 8.0  in whatever the rest of your UAS is.   You can try using  UAPick  to fix up what you have or to spoof something else.


Good luck
Robert Aldwinckle
---


Thanks for the suggestion Robert but we ruled out compatibility view early in the process.  Also This seems to be profile specific as other user on the same computer CAN add search providers.  One other thing.  We haven't tried UAPick because the sysadmins were out until this week.  We will give it a try if we can get the go ahead.

Thanks...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Got the answer to this.

 

IN my case I have one user with compatibilty settings set to all pages for her screen reader.

 

Effectively she's in IE7.

 

Turned compatibility view off, managed add ons, turned it back on.

 

Done.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.