Unable to view .mht files on local drive. But able to open the same file from mapped network drives.

I just upgraded from IE6 to IE8 and now unable to view .mht files that are launched from the local drive, in this case it is the C:\ drive.

If I view the .mht file from the C:\ I first get in the status bar the option to run a script or ActiveX. I select enable to run then I get Page cannot be displayed. If I copy the same file to a network drive in this case its J:\ drive going to a 2003 file server, I am able to open the file and do not get prompt to run the script or ActiveX in the status bar.

  1. One suggestion in a forum is to delete and re-add the .mht file extentions under Folder Options \ File Types and add them back. This did not help.
  2. Another suggestion was to select Internet Options \ Advanced \ Security \ Allow ActiveX to run from My Computer. Now I don't get prompted to run the ActiveX, but the page stays in the loading state and never displays the page or an error message, just hangs loading the page.
  3. I aslo modified the differant IE Security Zones and modified the registry so that I can view My Computer Security Zone and modified all those settings as well. This did not help.
  4. Last, I do notice when IE8 attempts to load the page from my C:\ drive, it says Unknown Zone. Then when it fails it goes to the Internet Zone. When run from a network drive, I get the Intranet Zone and works perfectly.... Maybe, I need to make my local drives on my PC trusted, but couldn't figure out the option that would work under the Trusted Sites Zone.

Thank you in advance for your help,

Don

 

Question Info


Last updated September 20, 2019 Views 16,953 Applies to:

Hi Don,

You have tried most of the steps. I would suggest you to try adding the website (which opens when you open .mht files) to trusted sites and check if it helps. Follow the steps from the below mentioned article link:

Security zones: adding or removing websites (This information applies to Windows Internet Explorer 7 and Windows Internet Explorer 8)


Hope this helps. Let us know if you need further assistance.

Thanks and Regards,
Santosh Y – Microsoft Support

Visit our Microsoft Answers Feedback Forum and let us know what you think.

[If this post was helpful, please click the "Vote As Helpful" (green triangle) button. If it helps in resolving your issue, click "Propose As Answer" or "Mark As Answer" button. By proposing/marking a post as Answered, or Helpful you help others find the answer faster.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for the response.

I'm actually not hitting a web site, I have the .mht file saved on my desktop (It's a Symantec 11.x canned report that is emailed to me everyday and it's the only file format that I can select, go figure.... ) I attempted to add the address with a wildcard but the trusted sites doesn't like the formats I'm attempting to use.

I do have some new t-shooting information to provide.

1. If I run the .mht file from my desktop or when I run it from as an attachment to my email. Both attempt to open the file under my profile directory. After I  approve to enable the activex to run in the IE window, it will change my URL address, it replaces my user name that has the "!" mark on the end and it converts it to a "_", after I allow blocked contents.... very odd.

* Address before enabling scripts:

C:\Documents and Settings\dbbabb!\Local Settings\Temporary Internet Files\Content.Outlook\D0P7V6TB\SEPM - Risk Report_Aug 18_ 2010 10-21-02 AM (2).mht

* Address after I select Allow Blocked Content, note that it changed the directory name that is my user ID.

mhtml:file://C:\Documents and Settings\dbbabb_\Local Settings\Temporary Internet Files\Content.Outlook\D0P7V6TB\SEPM - Risk Report_Aug 18_ 2010 10-21-02 AM (2).mht

* If I manually change the underscore back to an explanation mark for the URL address, I get an address not valid in IE8.

2. If I copy the same file to any directory that doesn't have the explanation mark "!"  in the path, it works and it doesn't add the prefix to the address:  mhtml:file:// , as well.

C:\Documents and Settings\dbbabb\SEPM - Risk Report_Aug 12_ 2010 10-20-11 AM.mht - This path will work and IE8 doesn't add mhtml:file:// to the address.

I know that I can now remove the "!" from my ID and it work, but the state agency uses the explanation mark, to ID all admin accounts. It's has been setup like this for many years now.

 

 

Don Babb

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey Don Babb,

 

Since you can use a different file location and everything works appropriately, this would suggest that the user profile/user profile folder has become corrupted. There are two options in this case:

1.      Move the Temporary Internet Files folder to a folder other than the dbbabb! user profile folder. (Such as C:/ or similar)

2.      Create a new user profile to see if the problem is fixed, and then move the user profile data over to the new user profile.

 

To move the Temporary Internet Files folder:

·        Create a new folder in the location you want Temporary Internet Files to be stored (Be sure to name the folder Temporary Internet Files)

·        Open Internet Explorer

·        Click Tools

·        Click Internet Options

·        Under Browsing history, click  Settings

·        Click Move folder…

·        Select the new folder you created above

·        Click OK

·        Click OK

·        Click OK

·        Restart your computer

 

To create a new user profile and move the user data over to the new user profile:

Note: You may want to consult your IT department before completing these steps, especially if you are on a Domain. They may need to complete these steps and any further troubleshooting depending on how your profile is setup/stored.

How to copy data from a corrupted user profile to a new profile in Windows XP

 

Hope that helps, look forward to hearing back from you.


Steven
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey Don,

I am not sure if you have found a resolution yet. But I can see the same behavior and it isn't too hard to reproduce. Save some webpage as MHT, say on C:, as "don.mht". Open it in IE8. It opens fine. Now rename the file and add a '!' to the name. This time it won't open. The same behavior can be seen when adding a '#' to the name. It would seem like a bug in IE8 to me because I am unable to find any other information regarding this from elsewhere.

Satwik.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem with ie9 beta when the path to the mht file has a !, but not when it doesn't.  (I add ! at the beginnings of some folder names so that they are sorted first by Windows, which I find to be a very useful trick.)

Don Babb's and Satwik's supposition therefore seems very likely.

wenn schon

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Don,

You have tried most of the steps. I would suggest you to try adding the website (which opens when you open .mht files) to trusted sites and check if it helps. Follow the steps from the below mentioned article link:

Security zones: adding or removing websites (This information applies to Windows Internet Explorer 7 and Windows Internet Explorer 8)


Hope this helps. Let us know if you need further assistance.

Thanks and Regards,
Santosh Y – Microsoft Support

Visit our Microsoft Answers Feedback Forum and let us know what you think.

[If this post was helpful, please click the "Vote As Helpful" (green triangle) button. If it helps in resolving your issue, click "Propose As Answer" or "Mark As Answer" button. By proposing/marking a post as Answered, or Helpful you help others find the answer faster.


IS MICROSOFT AWARE OF THIS EXCLAMATION-POINT BUG WITH INTERNET EXPLORER???  If an exclamation point cannot be allowed in a folder/directory name by IE it should generate an error message to that effect rather than starting to open a file and then hanging indefinitely until cancelled without ever opening the file.  How many people include an exclamation point in a folder/directory name is irrelevant since for those who do it is a time-consuming process of elimination to finally discover that it is a bug with Internet Explorer which could easily be updated with a fix or, if it can't be fixed, by having IE generate an explanatory error message.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The problem discussed in this threat is definitely caused by IE being unable to handle an exclamation point in the name of a local folder/directory and the behavior can easily be reproduced as Satwik indicates below.  I will paste what I wrote in reply to Santosh Y – Microsoft Support below before seeing that you're listed as the Forum Moderator/Support Engineer:

  • IS MICROSOFT AWARE OF THIS EXCLAMATION-POINT BUG WITH INTERNET EXPLORER???  If an exclamation point cannot be allowed in a folder/directory name by IE it should generate an error message to that effect rather than starting to open a file and then hanging indefinitely until cancelled without ever opening the file.  How many people include an exclamation point in a folder/directory name is irrelevant since for those who do it is a time-consuming process of elimination to finally discover that it is a bug with Internet Explorer which could easily be updated with a fix or, if it can't be fixed, by having IE generate an explanatory error message.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey Don,

I am not sure if you have found a resolution yet. But I can see the same behavior and it isn't too hard to reproduce. Save some webpage as MHT, say on C:, as "don.mht". Open it in IE8. It opens fine. Now rename the file and add a '!' to the name. This time it won't open. The same behavior can be seen when adding a '#' to the name. It would seem like a bug in IE8 to me because I am unable to find any other information regarding this from elsewhere.

Satwik.


I was having the same problem and looked around the web until I found this forum discussion.  I didn't have mht files with a # in the name, the # was in the folder name.  I moved the files to a different folder and the files opened up just fine.

I had been using a # in the front folder names to force them to the top of the folder list alphabetically.  So I changed the # to a & and was able to open all of the mht files, and the folder stayed at the top of the folder list.

Thanks for the tip, Satwik!!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.