Menu bar text is invisible

When accessing the Tools, Safety or Page drop-down arrow on the menu bar no text is displayed--it is invisible. Only the gray backgoround of the text is visible
 

Question Info


Last updated June 7, 2018 Views 2,804 Applies to:
Answer

Hello Dnwall,

 

Welcome to the Microsoft Answers Community!

 

This can occur for a variety of reasons, here are some steps to try to identify the cause and solution.

 

Internet Explorer (No add-ons):

·         Click the Start Orb

·         Click All Programs

·         Click Accessories

·         Click System Tools

·         Click Internet Explorer (No add-ons)

If you can see your menu text again, then you just have to find which add-on was causing the problem. You can do this by:

·         Click Tools

·         Click Manage Add-ons

·         Click Toolbars and Extensions

·         Under Show: click All add-ons

·         Click any add-on

·         Press CTRL + A on your keyboard (this should select all add-ons)

·         Click Disable all

·         Click Close

·         Close Internet Explorer (No add-ons)

·         Open Internet Explorer

Now all add-ons are disabled in Internet Explorer, next step is to enable them one by one.

·         Click Tools

·         Click Manage Add-ons

·         Click the first disabled add-on

·         Click Enable

·         Click Close

·         Surf a few pages

·         Close Internet Explorer

·         Open Internet Explorer

Check to make sure your menu items still appear correctly. If all is well, then the add-on you enabled is good to go. Repeat the enabling process for the next disabled add-on and continue this process until the problem returns. Once the problem returns you will need to take the last add-on you enabled and disable/uninstall/update it to avoid further problems.

 

Clean Boot:

·         Click Start

·         Type msconfig into the search field (if using Windows XP, click Run… and type msconfig into the Open: field)

·         Press Enter on your keyboard

·         Click Continue on the User Account Control (If prompted)

·         Click Selective startup

·         Uncheck Load startup items

·         Click the Services tab

·         Check the Hide all Microsoft services box

·         Click Disable all

·         Click OK

·         Click Restart Now

Once your computer has finished restarting, test to see if you still get the same problem in Internet Explorer. If not then you just have to identify which service/startup item was causing the problem.

·         Click Start

·         Type msconfig into the search field (if using Windows XP, click Run… and type msconfig into the Open: field)

·         Press Enter on your keyboard

·         Click Continue on the User Account Control (If prompted)

·         Click the Services tab

·         Check the Hide all Microsoft services box

·         Check (Enable) the top half of the service boxes

·         Click OK

·         Click Restart Now

Once your computer has restarted, again test to see if the problem is still gone. If so, then the services you enabled are good to stay. Repeat the enabling process for half of the remaining disabled services and continue this process until the problem returns or all services are enabled. If the problem returns then you will need to test the last batch of services you enabled one by one to find which was causing the problem to occur.

If you enable all services and the problem still hasn’t returned:

·         Click Start

·         Type msconfig into the search field (if using Windows XP, click Run… and type msconfig into the Open: field)

·         Press Enter on your keyboard

·         Click Continue on the User Account Control (If prompted)

·         Click the Startup tab

·         Check (Enable) the top half of the service boxes

·         Click OK

·         Click Restart Now

Follow the same process as before, with testing after each restart. If the problem hasn’t returned, go back and enable half of the remaining list of startup items and continue the process until the problem has returned. Then you will need to test the last batch of startup items you enabled one by one to find which causes the problem to occur.

Once you have identified which service/startup item causes the problem in Internet Explorer you will need to either disable/uninstall/update the program to avoid further problems.

 

Hope that helps, look forward to hearing back from you.

 


Steven
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

I am also having this problem. All of the drop down boxes on the right side of the page do not display thier texts. I also seem to have a problem of size on some of the fill in boxes. Like with this website when it asked me to give a name for me to be known as it was like size 0 font. I did everything that you stated before and I still have the problem. It only does it when I upgrade to IE8. IE7 works fine but I have websites that are horrid using IE7. If you cannot help me I don't know what I will do.

Becca Null


Hi,

In Internet Options> Advanced> Browsing, uncheck "Enable visual styles on buttons and controls..."

If you're running Stardock WindowBlinds, try disabling it. If you're running another themes manager, try disabling it.

See if a browser add-on is causing the problem.
Start Internet Explorer without add-ons by right-clicking the IE icon on the desktop. Choose Start without add-ons.
or
from Start> Programs> Accessories> System tools> Internet Explorer (no add-ons)
If the problem goes away, you have an incompatible browser add-on installed.

For troubleshooting information see:
IEBlog  Troubleshooting and Internet Explorer’s (No Add-ons) Mode:
http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx

Don

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.