"Internet Explorer cannot display the webpage"/"The address is not valid" for no reason

ok so here's what happened: i was having some issues w/ a website in firefox and figured it must b an "IE only" site (i've come across a couple of sites like that). so i open IE and after it says Connecting, it goes to a "Internet Explorer cannot display the webpage" page. however i noticed that for a split second before that it said "Antivirus Vista ALERT" (which i think is the cause of all this). i've done my research and to delete the Antivirus Vista ads in general (because there are many pop-ups that usually accompany this) all that is needed a run of Malwarebyte's Antimalware. i've done 3 runs and aside from finding some things to delete, nothing changed. 

 

i hit the dropdown arrow next to the homepage and found Antivirus Vista ALERT there. so i deleted it and now i get one of the 2 errors above. when i diagnose the error it says to check the proxy settings (no clue what to do there). here's what the address bar reads for each:

not valid:   http:///

c an't display (searching microsoft.com):    http://www.google.com/search?q=microsoft.com&rls=com.microsoft:en-us:IE-Address&ie=UTF-8&oe=UTF-8&sourceid=ie7&rlz=1I7GPEA_en

 

i have no idea what to do now, can someone tell me what to do (i'm thinking like uninstalling IE entirely, then reinstalling it). right now i'm open to all suggestions.

 

my specs:

computer-HP Pavillion laptop

OS-vista

IE version-IE8 (upgraded from 7 earlier today)

 

 

Question Info


Last updated June 15, 2019 Views 15,437 Applies to:
Answer
Answer
hey thanx for the help guys. it turns out all that was needed was this: 1) go to Control Panal 2) go to Internet Options 3) in the Connections tab, go to the LAN settings 4) check the "Automatically Detect Settings" box 5) uncheck the "Proxy Server" box then i had complete access to my iTunes store and internet explorer was back in working order (able to access all sites). it's a simple fix (no installation of anything really). hope this helps anyone else who has this problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.