Question

Q: IE 8 intermittently displays "Internet Explorer cannot display the webpage" error

Periodically that message appears when I try to access a web page. Hitting "Refresh" or the Enter key usually produces the web page I was seeking, but this happens far too often, and I would like to correct it. When receiving the page, I've gone through the steps in the "Diagnose Connection Problems" button, but it comes up with something like "Troubleshooter Could Not Identify the Problem." When I close that dialog box the web page I sought usually appears.

I have also run the troubleshooter on this page: http://support.microsoft.com/default.aspx/kb/956196, specifically Method 9, with the same result. Since this is an intermittent problem, I don't see that the other methods would help, since this only occurs about every third or fourth time.

I suppose I could reinstall IE 8, although I'm unable to find a tutorial on this for Windows 7, but would like to exhaust other methods first.

Answer

A:

Hey JimKW05,

 

Let’s try flushing your DNS and resetting your TCP/IP stack. To do this:

·         Click Start

·         Click All Programs

·         Click Accessories

·         Click Command Prompt (if you are using Windows Vista or Windows 7: right click Command Prompt and click Run as Administrator)

·         Enter these commands one at a time:

o   IPCONFIG /FLUSHDNS

o   NBTSTAT –R

o   NBTSTAT –RR

o   NETSH INT IP RESET

o   NETSH WINSOCK RESET

·         Restart your computer

 

If that doesn’t fix the problem, take a look at this KB article for troubleshooting steps for the “Internet Explorer cannot display the webpage”:

You receive an error message in Internet Explorer: “Internet Explorer cannot display the webpage”

 

Hope that helps.


Steven
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think

Did this solve your problem?

Sorry this didn't help.

Answer

A:

Hi twacapn,

Follow the path below to turn off and turn on Internet Explorer which is as good as uninstalling and reinstalling. See if that makes any difference.

Start> Type in Turn Windows feature on or off in the search bar>Hit Enter>Uncheck Internet Explorer 8 in the window that opens up>Select OK>Restart the computer and Check the box next to Internet Explorer 8 using the same path you followed to turn off the feature.

Let me know if it helped.

Regards
Varun J: MICROSOFT SUPPORT

If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.

Thanx for the suggestion, and I'll file this solution and use it if necessary, but I explained in this post that I had solved the problem, or at least about 97% of it:
Well, after I posted this question I kept searching for a solution, and I don't remember where I found it, but I fixed the problem by going, on a web page, to Tools-Compatibility View Settings, and in the window that appeared put a checkmark in the box next to "Display all web sites in Compatibility View" at the bottom. That was a few days ago, and the problem has only occurred a couple of times since then. Before it was occurring about every 3rd or 4th web site, so it is a great improvement. You may want to try it if you haven't already. Hope it works as well for you as it did for me.

Based on my philosophy of "If it ain't broke don't fix it," I'm not going to do anything else unless the problem recurs.

Did this solve your problem?

Sorry this didn't help.



 
Question Info

Views: 9,794 Last updated: May 17, 2018 Applies to: