Question
  • This thread is locked from future replies
21997 views

How to force IE to use HTTP/1.1 over SSL through Proxy

OldandEvil asked on
Internet Explorer sends SSL requests through a proxy as HTTP/1.0. How can I force it to use 1.1?
The registry settings do not change the request as stated in the KB articles.

I also noticed that the header field also adds "pragma: no-cache" which I do not want.

These apparently are the default settings for IE6-8 in which I cannot find a way to force 1.1 or change the no-cache.
6 people had this question

Abuse history


The answered status icon Answer
OldandEvil replied on

It took a long time to discover the causes.

1. The web server we were working with originally was misconfigured. Since it was apache, it had a setting
     "^Moz.*" downgrade-1.0 force-response-1.0
     This setting forced ALL browsers to use HTTP/1.0. So, all you apache admins, please DON'T put a setting on your web server to downgrade HTTP!

2. The second cause I found belonged to Blue Coat proxy. By default (if you have authentication enabled) any SSL connection going through a Blue Coat proxy will "Act" like HTTP/1.0. This is due to the authentication "mode" being set to 'auto' by default.
When the proxy has to 'auto' determine the mode, and each request will have to go through the process and the proxy treats them all as a new connection, forcing the SSL to re-negotiate and close each one. Changing it to "Proxy IP" is recommended by Blue Coat.
If you have authentication on your Blue Coat, then I would HIGHLY recommend changing the mode to the Proxy IP option. ALL your SSL traffic will be reduced, lowering your cpu utilization, network load, and all SSL web server loads as well!
Be the first person to mark this helpful

Abuse history


progress