Question
  • This thread is locked from future replies
171669 views

How can I install ActiveX Crystal Report Viewer for Internet Explorer 8 in Windows 7??? Please help :((

Musti The Dj asked on
I work as a teacher in my country and all of the teachers have to use a site for student's school marks, exams, etc. But the teachers, using Windows 7 with Internet Explorer 8, can not use that web page. Because whenever we try to take a report, IE8 asks for installing ActiveX Crystal Report Viewer Application. Answer is always "Install Application" but it does not install. waiting waiting waiting for hours and no installing and no solution.

Is there anyone who can help me?

Waiting for your respond....
48 people had this question

Abuse history


The answered status icon Answer
Zaki J replied on

Hi Musti The Dj,

Thank you for using Microsoft Answers Forum.

We can try these steps to help you fix this:

We can do a Clean Boot to make sure no third party programs are causing a problem. The steps are listed in this link:

http://support.microsoft.com/kb/331796

Secondly, we will try to optimize IE for Resolving this problem. 

http://support.microsoft.com/kb/936213 

Note: I would recommend you to disable Security Softwares on the computer.

We can also add websites; the steps are listed in this link:

http://windowshelp.microsoft.com/Windows/en-US/help/fd277a6b-3722-445b-b32e-1f8e925c385a1033.mspx

We can also enable the Active X Control by going to this Option:

Internet options> trusted sites> Custom level> Scroll down Active x controls and plug ins> enable Run Active x controls and plug ins

You can also refer to this link:

http://support.microsoft.com/kb/960321

Hope this information is helpful.

Let me know if this worked.

All the best!

 Regards,

Uma R – Microsoft Support Engineer

Visit our Microsoft Answers Feedback Forum and let us know what you think.

 

 

1 person found this helpful

Abuse history


The answered status icon Answer
sarovinet replied on

Thanks sarovi but it didnot worked :((


TEST Other Option is install manually:

The URL for the cabinet file for Crystal 11 (XI Release 1) looks something like this: http://yourwebsitewherecrystalisinstalled/crystalreportviewers11/ActiveXControls/ActiveXViewer.cab

Once you have extacted the contents to a folder on your hard drive, register the DLLs. You only need to register the DLLs that are not provided by the OS. For Crystal 11 (XI Release 1) the commands to register the DLLs are:

REGSVR32 /S CRVIEWER.DLL

REGSVR32 /S REPORTPARAMETERDIALOG.DLL

REGSVR32 /S SVIEWHLP.DLL

REGSVR32 /S SWEBRS.DLL

and ready

Be the first person to mark this helpful

Abuse history


progress