Can only access HTTPS sites and not HTTP sites

Hi,

I'm running windows 7 32 bit, with a wireless connection on a custom machine. I am connected to my network with internet connection too.

As the title suggests, i can only access HTTPS sites and not HTTP sites. I have recently had a virus that pretended to be Windows protection. This virus would not allow me to open any other programs and would also stop 'ctrl alt del' from working. I removed it by restarting, quickly accessing and opening certian files then removing it. I'm running Avira AntiVir Personal and after a complete scan it found TR\spy.gen2.exe  I have located the two places this was found and deleted it. I have re-run my virus checker and it comes clean now. After trying the internet i then came along the problem mentioned above. I have tried restoring to a previous restore point and also inserted the Windows 7 DVD and used the repair function. Neither have worked.

Any suggestions would be greatly appreciated

Bob

Answer
Answer

Hi gashton,

a. Is the issue with a particular HTTP site or all HTTP websites?

b. Do you get any error message?

Step 1:
Let’s check if you are able to use Internet Explorer in ‘Safe Mode with Networking’.

Below are the steps which talks about how to get into ‘
Safe Mode with Networking’:
1.     Restart your computer if it is powered on.
2.     Tap the F8 key after your computer initially powers on.
3.     Once you see the Advanced Boot Options menu you can stop tapping.
4.     Use the up/down arrow keys to highlight your selection.
5.     Select ‘
Safe Mode with Networking’
and press Enter.
6.     You should see drivers loading, and then please wait.
7.     You should then be at the Welcome Screen.
8.     Logon to your computer using an account with Administrator privileges.

Access the below link to know more about ‘Safe Mode with Networking’:
http://windows.microsoft.com/en-US/windows-vista/Advanced-startup-options-including-safe-mode

Step 2:
1.Open Internet Explorer by clicking the Start button. In the search box, type Internet Explorer, and then, in the list of results, click Internet Explorer.
2. Click the Tools button, and then click Internet Options.
3. Click the Security tab.
4. Reset all zones to default level.
5. Click on Apply.
6. Click Ok.

Access the below link for information on how to change Internet Explorer Security settings:
http://windows.microsoft.com/en-us/Windows7/Change-Internet-Explorer-Security-settings

Step 3:

Windows Firewall can prevent an HTTP connection. You can adjust the setting to allow HTTP connections by doing the following:

1. Go to your Control Panel by clicking the Start button then clicking on "Control Panel".

2. Click on "Network and Internet". 

3. Click on "Windows Firewall".

4. Click on "Change Setting" and then click on the "Exceptions" tab.

5. Under that tab, put a check mark next to the HTTP port 443. This should allow connections to HTTP sites.

6. Click "OK" on the Firewall settings and close the other windows.

7. Restart your computer and try to connect to the FTP site again.

Step 4:

If the issue still persists, re-register below files and check for the issue.

1. Click Start, and then click Run.

2. In the Open box, type one of the following commands, and then click OK (copy and paste is your best friend):

regsvr32 softpub.dll

regsvr32 wintrust.dll

regsvr32 initpki.dll

regsvr32 dssenh.dll

regsvr32 rsaenh.dll

regsvr32 gpkcsp.dll

regsvr32 sccbase.dll

regsvr32 slbcsp.dll

regsvr32 cryptdlg.dll

3. Click OK when you receive the message that says ‘DllRegisterServer in FileName’ succeeded.

4. Repeat for each command line listed above.

Hope this helps. Get back to us with results.

Regards,
Manasa P – Microsoft Support.

56 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated December 27, 2020 Views 35,822 Applies to:

Related Forums