Bing has taken over all of my browsers and is causing problems with my work-flow.

Vista Ultimate

Two days ago I noticed that the address bar search in all of my browsers (FF, Chrome, Opera, IE, and Safari) has been redirected to bing.com. Even worse, it appears that I can no longer access local servers on my network because according to bing they use improper syntax (ie: http://ourserver) not having a .com or anything. As a web developer no longer able to access our companies local servers this has been particularly damaging.

Is there any way to undo this problem. It seems to have coincided with a Microsoft update.

An extensive web search has found many people running into this problems in particular browsers, but in my case it has taken over my entire computer and I have been unable to find any solutions. I tried updating the config settings in each browser to no avail. I checked my hosts file and it looks fine. I do not have the Bing toolbar nor any other search enhancing add-ons in any browser.

Any help would be much appreciated. Thanks.

 

 

Question Info


Last updated October 29, 2018 Views 8,592 Applies to:
Actually, it has only taken over the address bar search in a few browsers, but has taken over the improper url behavior in all of them.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Is there any way to undo this problem. It seems to have coincided with a Microsoft update.

No. Also, if you think this is a bing problem, please go to bing.
As a general advice: disable searching from the address bar.


IEFAQ: http://iefaq.info Newsgroup: microsoft.public.de.internetexplorer
--
FAQs für IE/Edge: https://answers.microsoft.com/de-de/ie/forum/ie11-iewindows_10/wo-sind-die-faqs-hier/11609262-76d9-4143-b2a0-6d2c8ab35cfc (Dies ist eine Signatur.)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Addendum: you may want to scan for malware and ensure that it is really bing that you see.


IEFAQ: http://iefaq.info Newsgroup: microsoft.public.de.internetexplorer
--
FAQs für IE/Edge: https://answers.microsoft.com/de-de/ie/forum/ie11-iewindows_10/wo-sind-die-faqs-hier/11609262-76d9-4143-b2a0-6d2c8ab35cfc (Dies ist eine Signatur.)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 

Two days ago I noticed that the address bar search in all of my browsers (FF, Chrome, Opera, IE, and Safari) has been redirected to bing.com. Even worse, it appears that I can no longer access local servers on my network because according to bing they use improper syntax (ie: http://ourserver) not having a .com or anything. As a web developer no longer able to access our companies local servers this has been particularly damaging.

Is there any way to undo this problem. It seems to have coincided with a Microsoft update.


Why are you using the Address bar as a search bar?   Use the Search bar, e.g. press Ctrl-e and then type your query there.

The symptoms that you are complaining about suggest that you have disabled search from the Address bar (e.g. in Options, Advanced tab, Search from the Address bar section) and that your ISP's DNS has a feature which does a search for you when you enter partial or invalid domain names and that that search just happens to be BING.   None of that would happen if you used the Address bar only with complete valid URLs and did any searches you need to do only in the Address bar.

 

Alternatively, if you must use the Address bar to search from, you should use the question mark space prefix (? ) as a signal that you do not want a DNS lookup to be done on what you are entering there.   That feature has been there since at least IE4 but I think that getting into the habit of pressing Ctrl-e instead would be more useful to you.


HTH

Robert Aldwinckle
---

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the replies.

To clarify: the problem is not the search, I can do that from the search bar, the problem is that I can no longer access servers that don't have a .* extension. For example, there is a server on our network that I would normally access via http://ourserver (similar to going to http://localhost), however now I am redirected to bing instead. This is happening in ALL of my browsers, and I know it's not an ISP issue because none of the other machines on our network have this problem (incidentally, none of them have updated recently either).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

To clarify: the problem is not the search, I can do that from the search bar, the problem is that I can no longer access servers that don't have a .* extension. For example, there is a server on our network that I would normally access viahttp://ourserver (similar to going tohttp://localhost), however now I am redirected to bing instead.

Which means, there *is* a search enabled for your addressbar and the address is not resolvable. Disable searching from the addressbar.

This is happening in ALL of my browsers, and I know it's not
an ISP issue because none of the other machines on our network have this problem (incidentally, none of them have updated recently either).

If it is not your ISP or a DNS that you use then it is on your PC, yes. But not in IE. You must have installed a software that changed for instance the DNS settings.

Is there any chance this could apply?
http://www.h-online.com/security/news/item/Microsoft-installs-another-Fire
fox-add-on-without-asking-users-permission-1021221.html


IEFAQ: http://iefaq.info Newsgroup: microsoft.public.de.internetexplorer
--
FAQs für IE/Edge: https://answers.microsoft.com/de-de/ie/forum/ie11-iewindows_10/wo-sind-die-faqs-hier/11609262-76d9-4143-b2a0-6d2c8ab35cfc (Dies ist eine Signatur.)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

To clarify: the problem is not the search,


Well, that is certainly different from your first sentence in your OP.   However, I don't think that you have yet clarified what syntax you are trying to use in the Address bar.   E.g. I wouldn't be surprised to see your symptom if you were entering your server name without a protocol prefix and perhaps without a trailing slash.   Perhaps you should also give the parser a port number to chew on?   E.g. try

     http://ourserver:80/

; )

Also, what happens if you try to use a proper link to your server and bypass the Address bar entirely?

BTW have you tried using netmon or Wireshark to see exactly what is happening at the TCP packet level?   E.g. perhaps a lookup request is being done which should not be done?   (Then you could try using your HOSTS file as an override to prevent that.)

Another approach to taking the diagnosis on that tack would be to see what ping -n 1 -w 1  ourserver  does.    Check with  ipconfig  /displaydns  |  findstr /i "ourserver live"   (in a cmd window).   E.g. if you can get the lookup cached (for however long the Time To Live is and that is sufficiently long to be usable by IE) you could let IE use the dnscache that way without having to modify your HOSTS file.


Good luck

Robert
---

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Is Vista SP1 or SP2 installed?

Is Windows Live, MSN, and/or Bing Toolbar installed?

       • An update is available that improves the homepage category functionality for Windows Live Toolbar, for MSN Toolbar, and for Bing Bar
         http://support.microsoft.com/kb/982217 (08 June 2010)

• Microsoft hides mystery Firefox extension in toolbar update:
http://arstechnica.com/microsoft/news/2010/06/microsoft-slips-ie-firefox-add-on-into-toolbar-update.ars

• Microsoft explains mystery Firefox extension, "fixes" update
<QP>
...this particular [update] does not show up in Control Panel => Programs and Features => Installed Updates. Furthermore, the Uninstall button for the extension is greyed out in Firefox. Internet Explorer, meanwhile, does not have uninstall options for add-ons: only Enable and Disable buttons are present.

Microsoft gave us the following instructions to remove the extension...
</QP>
Source & much more: http://arstechnica.com/microsoft/news/2010/06/microsoft-explains-mystery-firefox-extension-fixes-update-1.ars

~~~~~~~~~~~~~~

<QP>
The company says it has now, um, updated the update, and the silent toolbar install no longer occurs. The company calls the silent install "a bug."

"We discovered a bug in the latest update that was installing the Firefox extension for users with the Windows Live Toolbar and MSN Toolbar (specifically people who have not upgraded to the latest version of the Bing Bar)," the company tells us. "We fixed the update so that going forward folks who still have only the older Windows Live Toolbar or MSN Toolbar will not see this behavior anymore."

The company apologizes for any inconvenience this may have caused.
</QP>
Source:
http://www.theregister.co.uk/2010/06/11/microsoft_slips_firtefox_add_on_into_software_update

       
--
~Robear Dyer (PA Bear)
Microsoft MVP (Windows Client) since October 2002

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.