IE11 Compatibility Mode

I installed the preview with no problem and love the new features.  But now I am having trouble logging into my Citrix controlled company remote access account in IE11.  When trying to log in, it simply says that my credentials are wrong.  That is definitely not the case as I can log in just fine on an older version of IE, including IE10.  In the past, I would use compatibility mode to remedy issues like this.  But the option isn't there any longer.  For IE11, I read that if a page needs to be viewed in compatibility mode, the option will appear.  So I guess IE11 doesn't think I need the option for this particular site, but I think otherwise.  Is there a way I can force compatibility mode?  Or are there any other suggestions I can try?

 

Question Info


Last updated May 1, 2018 Views 23,019 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Is there a way I can force compatibility mode?

As an end user?  Use Developer Tools, Browser mode (F12, Alt-B).  And there may be a way to do it more permanently by exploiting the  %LocalAppData%\Microsoft\Internet Explorer\IECompatData\iecompatdata.xml  file, at least as an administrator.  

As a web developer you can certainly do that via meta data.  In contrast see

http://www.modern.ie/en-us/cross-browser-best-practices


 
FYI

 
Robert Aldwinckle
---

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm definitely on the user end and I really appreciate your help.  I tried changing the user agent string to a different web browser, but that didn't help.  I tried what you suggested as well and had no change.  I also added the site to view in compatibility mode, but though I noticed a slight change in the web site's appearance, it still wouldn't recognize my login credentials.  Any other suggestions?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

still wouldn't recognize my login credentials.  Any other suggestions?

What are your symptoms exactly?  Try using the Developer Tools, Network Capture tool to get a clearer idea perhaps?  Sounds like you might be using the wrong authentication protocol, in which case you might have to try forcing a lower level of negotiation.  For example, certain large banks apparently cannot handle  TLS 1.2  and then their users need to disable that option.   Change that (if you like) in Options, Advanced tab, Security section.

 
Good luck

Robert
---

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Was TLS 1.2 used with IE10 as well?  I think it was and I had no issues logging in.  Everything was fine and I logged in with no problems on my Surface Pro before the 8.1 install.  Now, when I put in my credentials and click submit, the password disappears and it says my credentials are wrong.  I know the credentials are correct because I can log into it just fine on another computer or in another browser on the same computer. 

I'm not sure how to use the Developer Tools or Network Capture tool.  So far, I've changed the user agent string to emulate IE10, IE9, etc. and I still can't log in.  However, if I open and use the Chrome browser, I can login just fine.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Press Alt, go to Tools, and click on Compatibility View Settings...add it there and see if there is a change...looking at default settings in IE10 vs IE11, only TLS 1.0 was checked by default, if after compatibility view it doesn't work, try disabling TLS 1.2, if that doesn't work, disable TLS 1.1 as well...if it works, see if disabling only TLS 1.1 allows it to work, otherwise keep both off...hope this helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks very much Michael this has been very helpful. I was having a similar issue with my organisational Citrix logon on instances of Windows 8.1 with IE 11. The Citrix landing page was blank apart from the background colour, none of the page elements appeared at all. There was no problem on the same hardware and OS software with Chrome 27.

I was trying to debug without success despite checking my certificates, Internet Explorer security and advanced settings line by line against IE 10 on Windows 8, again on the same hardware with dual boot.

Alt > Tools > 'Compatibility view settings' at the affected webpage and adding the site to the compatibility list solved the problem. The page elements reappeared and logon works as expected. I have tested this on Windows 8.1 under Bootcamp on a MacBook Air 2013 and Citrix logs me into my organisation remote desktop.

Thanks again. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks again for the help, but after trying your suggestions, it still isn't working.  I disabled TLS 1.1 and 1.2 , though I'm not exactly sure what those are.  I had already added the site in Compatibility View settings like Straker135 as well.  Once again, I can login through Chrome with no issues.  Is it possible that SSL has anything to do with it?  I'm not sure if SSL 3.0 was in IE10, but it is checked by default here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hmm I have found a new problem with IE 11. My banking site kicks me out every time I try to finalise a transaction. The site is in the Trusted Zone and selected under Compatibility View but still boosts me out when I try to select 'Next' or click 'Enter' at the end of transaction entry. Chrome is fine on Win 8.1.

This is rather frustrating and must be addressed by the time of RTM of IE 11. Ordinary users will be very unimpressed when many of their existing secure sites and services suddenly stop working...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have this same problem.  Cannot get Citrix web login page to work correctly.  By observation, it appears that one of the forms fields is blanked out right before posting the form.  This prevents me from remoting in to my work PC and on Surface RT I have not yet found a work around...
SQL MCP

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found a solution mentioned in another thread and it works for me.


1.) Add citrix login site to Compatibility list

2.) View the login page In Private


Strange solution, but it works!

SQL MCP

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.