Some images and content not displayed as well as some links not working in IE11

Hi I've bought a new Dell PC to run Solidworks 2015 at home. I can't get it to install as the "next icon" in the installation manager doesn't work. A prerequisite of the software is to have internet explorer 9, 10 or 11. 

I opened up internet explorer (to check it) and found some of the images missing on MSN home page. Going onto various websites have similar issues. Pictures not displaying and links not working if they have an icon/image rather than text. I have installed other internet browsers just so I can see all the content and links on the Microsoft help web site.

I have run through all the suggestions on the MS site such as the fix software, everything is set to default, deleted the history, changed settings to show images Created 2nd user accounts etc. Windows is fully up to date as is Java.

Below is an example of MSN homepage displayed in IE11

compare with MSN homepage in Google Chrome

Missing links in IE11. Also note for example the "was this page helpful?" question - none of the answers can be "clicked on"

Links visible in Google Chrome 

Thanks Chris

 

Question Info


Last updated October 4, 2018 Views 23,305 Applies to:
Answer

Hi Chris,

At this point of time, I would suggest that you try to uninstall and reinstall the Internet Explorer and check if it works.

Here's how you do it:

1. Open an elevated command prompt.

2. Copy the command below:

FORFILES /P %WINDIR%\servicing\Packages /M Microsoft-Windows-InternetExplorer-*11.*.mum /c "cmd /c echo Uninstalling package @fname && start /w pkgmgr /up:@fname /quiet /norestart"

3. In the elevated command prompt, paste the command from above, and press Enter in the command prompt.

4. If you get any error messages (like: Operation Failed with error code0x8007005 Access Denied), then click on OK to continue. You may get a few of them and it’s completely fine

5. When finished, restart the computer.

Now regarding the installation of the program, please navigate the following link:

http://windows.microsoft.com/en-us/internet-explorer/ie-11-worldwide-languages

or http://www.microsoft.com/en-us/download/internet-explorer.aspx and follow the on screen instructions.

Hope this helps.

Please get back to us with the updated status on the issue.

Regards.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.