Problems with Internet Explorer 11 in Windows 7 computer

I am having certain problems using Internet Explorer 11 (on my computer using Windows 7  Professional).  These problems are not occurring in any other browser, including Chrome, Firefox and Lunascape.  If I use the Trident browser engine in Lunascape (which allows for use of 3 different browser engines), things function normally.  In IE 11, even though it is also supposedly using Trident, I have problems.  These are the problems, which may or may not be related:

 

1) On msn.com, there is only one photo – the large one at the top.  In all of the other locations where one would normally see a small photo, there is a grey box, instead, with the text intact next to each.  If I select one of the items represented by the grey box, it goes to a webpage with text only – there is no picture there, either.  (Note:  It I go to msn.com on any other browser, it appears normal, with pictures where the grey boxes are in IE11 and pictures on the next page, if selected.)

 

2) I tried to go to “help” from the msn.com webpage, but when it goes to support.microsoft.com, the whole page is white.  I tried typing in the address in a new tab – it still goes to a blank white page.  The search engines I have set up in IE11 all work fine.  I looked for a topic matching my question by searching.  When I went and tried to connect via the results list to a specific topic on support.microsoft.com – again, it only resulted in a blank white page.  I copied and pasted multiple support.microsoft.com web addresses (the main address and addresses for specific topics) into other browsers and they all worked fine in the other browsers. 

 

Other websites seem to load normally in IE11, at least as far as I can tell.  I tried to reset the Internet Explorer settings, but that didn’t help (and yes, I did shut down my computer and then restart before checking this).  Am I going to have to uninstall and then reinstall Internet Explorer 11?  Is IE11 even still available for download?  (I am pretty sure it is still supported in its latest version, which I thought was IE11.)  If I do uninstall and then reinstall, is this likely to fix the problem – or is this an inherent problem of IE11 on computers run on Windows 7 Professional? 

 

Question Info


Last updated April 18, 2019 Views 3,892 Applies to:
Answer
Answer

Well, I decided to go ahead with trying to use the tool you mentioned.  I went to the page you linked to with “CheckSUR” – The instructions were pretty easy to follow and explained that the tool automatically runs as it is being installed.  It seemed to go smoothly.  At the end, it said “Installation complete”, at which point the instructions said to “close”.  Based on the instructions, I was expecting that if the tool had detected any corruption errors it couldn’t fix, it would list them.  Nothing was listed.  So, I figured, either there were no corruption errors, or any that were found were fixed.  However, after I shut down my computer and then booted it up again, I went into IE and the problems were not fixed.  

Assuming that means you were looking at the CheckSUR.log that is output by the tool I guess you would be right.

Next I tried to follow your instructions about using the “System Info” window (msinfo32).  Under “Software Environment” I found the “Loaded Modules” you mentioned, but there were no “IE11 Modules” listed there.  I did find one item for IE under “Services” – it was labeled: “Internet Explorer Collection Service”

Finally, I went to my IE and checked the specific version listed there (for “the last update it thinks it is using” – I love how you put this!).  The version listed in IE was: 11.0.9600.18638.  Then, using the link you provided, I got a big Excel Spreadsheet with listings of versions for various OS.  Under Windows 7, I found that the most recent update listed was:  11.9600.18639.  So, the numbers are off by one digit.

In fact, an example of an IE module which would be loaded even if IE itself was not is wininet.dll--essentially anything that starts with 11.0.9600 so sorting by Version in that display may show you that one last.  Sounds like you are up-to-date or almost up-to-date, so that looks good.

Coincidentally I started helping someone with a related problem today and the suggestion there is something that you could try too

https://answers.microsoft.com/en-us/ie/forum/ie11-iewindows_10/suddenly-cannot-access-websites-with-ie-11-on-win/8c9791bd-845d-4645-b9bb-8c4884d45baa?page=3 

<quote>

try some regsvr32.exe commands.
</quote>

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.