Add-ons are not disabled in iexplore.exe –extoff

Original Title: I am using IE11 "iexplore.exe –extoff" but add-ons are not disabled...

I am trying to setup IE11 to sometimes use add-ons and sometimes not.  Basically in order to get functionality as desired, one program requires the adobe add-on, while another program requires it to be off. 

So I tried starting IE11 using the "Internet Explorer (No Add-ons)" shortcut, and it tells me that the add-ons have all been disabled, but they have not.  The 2 indications that they are not are:

  1. When I click manage add-ons, the adobe add-on shows as enabled
  2. It is still opening pdfs in a new tab (which is driven by the adobe add-on and what I want to stop), but when I manually disable the add-on the pdf will open in my pdf viewer (outside of IE), which is what I want.

Manually toggling the add-on doesn't work as desired because the other program seems to require enabling the adobe add-on and the logging off the computer and then locking back on...I need more seamless switching (like using one shortcut for one program and another shortcut for the other program).

How do I get IE11 to run a shortcut with the add-ons disabled (when -extoff is not working), but only when I ask it to (so not a manual toggle which would effect all open IE windows?

Thanks!

Hello,

Thank you for posting your query on Microsoft Community.

As per description, you are facing issue with adobe add-on not getting disabled while running Internet Explorer in no add-ons.

iexplore.exe –extoff command disables add-ons temporarily. If some add-on is not getting disabled even after running in no add-on mode.

I would suggest you to follow the method given below and check.

Method 1: Run the Internet explorer performance troubleshooter.

Internet explorer trouble shooter provides the solution to some common problems with internet explorer. And it tries to fix problems automatically.

Follow the steps:

  1. Click on Start. Go to Control Panel.

  2. Change the category view by large icon.

  3. Select Troubleshooting.

  4. Click on view all and select Internet explorer performance.

  5. Click next and follow the on-screen instructions.

If issue still persists try method 2.

Method 2: You can reset Internet Explorer settings to return them to the state they were in when Internet Explorer was first installed on your PC. This can be useful for troubleshooting problems that might be caused by settings changed after installation.

Change or reset Internet Explorer settings

http://windows.microsoft.com/en-in/internet-explorer/reset-ie-settings#ie=ie-11-win-7

Note: The Reset Internet Explorer Settings feature might reset security settings or privacy settings that you added to the list of Trusted Sites. The Reset Internet Explorer Settings feature might also reset parental control settings. We recommend that you note these sites before you use the Reset Internet Explorer Settings feature.

Hope the information helps. Let us know if you need further assistance with Windows, we’ll be glad to assist you.

Thank you

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So I tried starting IE11 using the "Internet Explorer (No Add-ons)" shortcut, and it tells me that the add-ons have all been disabled, but they have not.  The 2 indications that they are not are:

  1. When I click manage add-ons, the adobe add-on shows as enabled
  2. It is still opening pdfs in a new tab (which is driven by the adobe add-on and what I want to stop), but when I manually disable the add-on the pdf will open in my pdf viewer (outside of IE), which is what I want.

That's normal.  The No Add-ons shortcut is just a means of simulating having all add-ons disabled, not actually disabling them.   As for opening something in a new tab that does not necessarily involve ActiveX.  Also you don't need the Adobe add-on to get .pdf files you can open them in the Reader instead of in the browser.  Adobe Reader has an option for this.  I don't have it installed any more but IIRC the option was accessed by Ctrl-k.

How do I get IE11 to run a shortcut with the add-ons disabled (when -extoff is not working), but only when I ask it to (so not a manual toggle which would effect all open IE windows?

It probably would help to know more about your requirement.  For example, if it could be differentiated by a host name you could instead put that into the Restricted Sites zone and then it would not be able to use ActiveX (e.g. because of that zone's default for that setting.)

 

FYI

Robert Aldwinckle
---

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for your reply.  For Method 1, I do not see Internet Explorer Performance, even though I selected view all.

Performance is the closest thing and it does not show any fixes related to IE.

Also, I have recently reset IE11, but can do this again if the other method doesn't work. 

I was playing around in the no add-ons session and noticed that some seem to be disabled, however the one I want, Adobe, is still opening pdfs in a new tab even though when I manually disable the add-on, it opens in my default pdf viewer outside of IE.

Thanks again for your help, and any more suggestions that you may have!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

do not see Internet Explorer Performance

So you probably have Home Premium.   FWIW I have only seen that feature on higher levels of Windows.  I have asked more than once when this issue is raised this way if the same tool is available for download, with no response.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So you probably have Home Premium.  

No, I am using Win7 Enterprise with SP1.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That's normal.  The No Add-ons shortcut is just a means of simulating having all add-ons disabled, not actually disabling them.   As for opening something in a new tab that does not necessarily involve ActiveX.  Also you don't need the Adobe add-on to get .pdf files you can open them in the Reader instead of in the browser.  Adobe Reader has an option for this.  I don't have it installed any more but IIRC the option was accessed by Ctrl-k.

...

It probably would help to know more about your requirement.  For example, if it could be differentiated by a host name you could instead put that into the Restricted Sites zone and then it would not be able to use ActiveX (e.g. because of that zone's default for that setting.)

Robert, Thanks for the tips.  Adobe has changed some settings in later versions, and in Adobe XI, Ctrl+K (which is the right command), brings up the page but it basically tells you to use the add-on to view pdfs inside the browser. 

The add-on that I referred to and which controls whether the pdf will open in an IE window or stand alone pdf viewer, is called "Adobe PDF Reader".

  • Manually Disabling Effect: PDF opens in your OS (Win7 for me) default pdf viewer
  • Manually Enabling Effect: PDF opens in an IE tab or window (using adobe, regardless of default pdf viewer)
  • With the Adobe PDF Reader add-on enabled but running using the no add-on switch "IE (no add-ons)" ( "C:\Program Files\Internet Explorer\iexplore.exe"  -extoff ), pdfs open in IE.

Any idea how to control get that it so I can open an IE window with that add-on disabled, but would not affect other IE windows where it is enabled?  It seems that this -extoff should work, however it is not...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No, I am using Win7 Enterprise with SP1.

I have never seen that but would wonder if some features are being suppressed by GPO or by simply not being installed somehow. 

OMG.  I have it (in W8.1.2 Pro) but I can't see where it would come from (e.g. in %windir%\diagnostics\index).   Further ProcExp is being inhibited from showing how it opened.  Oh. ProcExp had to be elevated to see this:

"C:\windows\System32\msdt.exe" -ep TSControlPanel -path C:\windows\Diagnostics\Index\IEBrowseWebDiagnostic.xml -context {3298527C-5304-4525-BFD0-8811367945DE}

That looks like the IE Browser one.  But the title is "Internet Explorer Performance" 

Troubleshoot and help prevent computer problems 

Internet Explorer Performance

Find and fix problems with Internet Explorer performance

What's the difference?  Maybe it is because I am running elevated?  (Or maybe it is just the IE Browser troubleshooter with an invalid context which then defaults to the IE Performance Troubleshooter.  <eg>)

Then in that case you could see what you get from an elevated cmd window (aka Administrator Command Prompt) and enter this:

msdt.exe  -?

That then gives the option to open the troubleshooters.   So I picked that one but now the -context is different.  ProcExp is not showing me if that is elevated.   Task Manager says  No.

"C:\windows\System32\msdt.exe" -ep TSControlPanel -path C:\windows\Diagnostics\Index\IEBrowseWebDiagnostic.xml -context {1CD5EAF7-D369-4490-837B-AC9C69E48E35}

OTherwise it looks the same.

Heh.  In an elevated PowerShell window, current directory at  C:\Windows\Diagnostics\Index I did this

PS>. msdt.exe -id IEBrowseWebDiagnostic

and appear to be getting the same thing but according to Task Manager this one is elevated.  So that might be easier if it is the same thing.   I don't really want to try this experiment myself because I suspect all it is is an enforced RIES.

 


FYI

Robert
---

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

same here, that does not exist on the menu !!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated April 16, 2020 Views 2,794 Applies to:

Related Forums