Windows 10 wifi error "No internet, secured" solved

Hey there! This is also a method for those  experiencing this problem for days and didn't solve it

Few steps to change this:

1. Go to Control Panel >Network and Internet> Network Connections

2. Choose your wifi connection, right-click and select Properties

3. In the Wi-Fi Properties, in the "This connection uses the following items:" tab, you should check the following options:

  •     Client for Microsoft Networks
  •     File and Printer Sharing for Microsoft Networks
  •     Link-Layer Topology Discovery Mapper I/O Driver
  •     Internet Protocol Version 4 (TCP/IPv4)
  •     Reliable Multicast Protocol
  •     Internet Protocol Version 6 (TCP/IPv6)
  •     Link-Layer Topology Discovery Responder

If it doesn't change for the moment, try to disable and then enable your wi-fi
It took me a week to figure it out.. I know how frustrating this problem was.

I hope it works for you to! :)

 
Discussion Info

Last updated August 16, 2018 Views 353,351 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I had to install reliable multicast protocol... It's still not working.  

Hi,

Are you connected to a domain network?

 

You may refer to the article given below and check.

https://support.microsoft.com/en-us/help/10741/windows-10-fix-network-connection-issues

 

Hope this information helps. Please let us know if you need any other assistance with Windows in future. We will be happy to assist you.

Reliable Multicast Protocol does not show up for me as an option to install, I also have a couple extra things installed.

Hi,

Did you refer to the article mentioned above by me and check?

If yes, what were the results?

 

Please let us know if you need any other assistance with Windows in future. We will be happy to assist you.

Hi Mayank,

Executed the networking commands provided in link, my issue got resolved. Thanks...

Hi,

I found this forum while looking for a solution to my wi-fi problem. I did refer to the article cited on how to fix network connection but none worked. Is there any other way? The problem still persists where I am connected to the wifi but it says "no internet" whilst all other devices (e.g. iphone, ipad) are connected to the network and working fine.

Please let me know if there is any other solution available.

Thanks!

I'm in the same boat. My phone and tablet are happily connected to my wifi, but my Win10 laptop keeps giving the "no Internet, secured" notification despite the fact that I've tried everything on this page and several others. It's extremely frustrating!
Exact same here.  I've tried everything in this link and then some, restarting after each small change.  No result.  Very strangely, I can connect using my phone's hotspot, but I won't have enough internet from that to continue indefinitely.
Well, after install this Reliable Multicast Protocol, my wifi being normal again, thanks mate

This issue drove me crazy.  I reset the whole machine and when it restarted had same problem.  "SECURED - NO INTERNET". 

I just installed the Reliable Multicast Protocol and seems to be working.... 

Okay,  I take that back.  Now it says that it's connected but browser can't load any pages. 

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.