IE11 has stopped saving my browser history for no reason that I can see - any ideas?

As of last weekend IE11 is no longer retaining my browser history during a browser session even before I've closed the browser! I haven't knowingly changed anything, any idea what could be causing this?

 

Question Info


Last updated September 13, 2019 Views 179 Applies to:
Answer
Answer

Hello Roger,

Regarding your concern about history not being saved on your Internet Explorer 11, we recommend these troubleshooting steps below: 

Method 1: Check Internet Options Settings

  1. Click the gear icon on the upper right hand corner of Internet Explorer.



  2. Go to Internet Options.
  3. On the General tab, ensure that the Delete browsing history on exit is unchecked.



  4. Hit Apply, then OK.

Method 2: Check AutoComplete Settings

  1. Follow the same steps on how to get to Internet Options as described above.
  2. Go to Content tab.
  3. Under AutoComplete, click Settings.
  4. In AutoComplete settings, browsing history option should be checked.



Method 3: Reset Internet Explorer

We highly suggest you Reset Internet Explorer settings and check if it helps.

Note: Please keep in mind that resetting your browser will reset security settings or privacy settings that you added to the list of Trusted Sites. This feature also resets parental control settings, will clear cache and website cookies.

Let us know what happens after.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.