LAN Connection settings keep changing back to proxy server after restart.

I recently purchased a laptop with Windows 8.1. For some reason, the LAN Connection Settings keep defaulting to use a proxy server (IP Address 127.0.0.1). I also have IE 11 installed. I am not entirely sure if it happens just after booting or if it only happens when I try to open an app on the tiles screen. In my most recent scenario, I immediately checked my Internet Options and "Automatically Detect Settings" was checked and proxy settings were unchecked. However, I then tried to open a weather app from the tiles screen and noticed it wouldn't update. I opened Internet Options and saw that it had changed to use a proxy server instead. Based off of other articles on here, I tried the following two fixes without success:


Method 1: 

Check the permissions on Internet Settings in registry



 ...

 

Method 2:


I would suggest you to Reset Internet Explorer settings and check if it helps.


 

Reset Internet Explorer settings: http://windows.microsoft.com/en-IN/internet-explorer/change-ie-settings#ie=ie-10


I have only owned this laptop for 3 days, so I'm not sure if it didn't do this from the time I first logged in or not. I did add an Office 365 email account on the email app and a window popped up that said Windows security settings would have to be automatically modified in order to add that type of email. I'm not sure if that kick started the problem or not.

 
Question Info

Last updated August 16, 2018 Views 739,619 Applies to:
Answer

Malwarebytes

Before doing anything else here as it can get quite complicated I suggest you download Malwarebytes run a scan (you can skip the update majority of the time if it asks) once completed remove/quarantine selected(defaults selects all) this will remove malware/virus/adaware from your computer, you may be asked to restart, do so and your issue may be resolved.


CCleaner

If you continue to have issues the next step is to download CCleaner, open CCleaner, you can run the cleaner if you wish (this will free up some hard drive space) the registry one may also fix the issue but most likely its an internet explorer addon that's causing the issue, go to "Tools" select "Startup" there might be some things in the list showing that shouldn't be there, things that have no publisher/unknown publisher are virus's you can disable them at will, Symantec pointing device driver is your mouse if you have a laptop so don't disable that, anyway go to the "Internet Explorer" Tab, you can disable pretty much everything but keep Java, you can also delete items here as well as some enable themselves again, just try disabling them first, try the internet again, if it doesn't work continue reading.


Proxy settings

By default it will keep proxy lan settings enabled something similar to this:

Proxy server enabled, if you untick and click okay the settings will not change. this is not relient on restarting the computer or anything else that you would assume it simply will not turn it off.

If LAN Settings is Greyed out or it only resets on system restart Open "Regedit" from your start menu

navigate to [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\
Internet Settings]

right click and create a new DWORD 32bit

name it: "ProxySettingsPerUser"

double click and modify to 1

If it already exists just double click and change it to 1

click okay and restart your computer

you should then be able to change your proxy settings (turn them on/off as desired)

If it still doesn't work, continue reading how to manually force it.

If you want to disable the proxy server its usually as simple as unticking the "use proxy server" box. in windows 8.1 this is not the case, upon closing that dialogue box it will sometimes reset back to being enabled again. The only way i have found around this is as follows.

Tick the "Use automatic configuration script"

Type in "http://localhost/proxy.pac" without the quotation's

Untick "Use a proxy server for your LAN"

The proxy.pac address must use // and not \\ as for some reason if you use the lan address it automatically changes it back to using the lan proxy. dont worry if you do not have a proxy.pac file if you have "automatically detect settings" selected it should default to no proxy. but stupidly enough this is the only way to disable a proxy server in windows 8.1

(this has happend a few times randomly with windows 7 enterprise and resetting internet explorer to defaults fixes this, in windows 8.1 however that does not help at all)


Test again, see if your internet is working.


Problem persists

You can also manually set it through registry editing.
Windows key + R

Type in "Regedit" without quotes

Press enter

Navigate to the following and make sure they are disabled.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\
"MigrateProxy"=dword:00000001

1 for enable 0 for disable


"ProxyEnable"=dword:00000000          

1 for enable 0 for disable


"ProxyHttp1.1"=dword:00000001       

1 for enable 0 for disable Might also be "ProxyHttp1_1" on some machines


"ProxyServer"=""        This is blank (if there's a value Delete it)

if you are actually using a proxy server, the format is IPaddress:port


If the registry Keys above aren't shown Add them.

Right click New>DWORD(32-bit Value)


give it its name, right click and Modify... type in its value from above.



Still not working

if that still doesn't work there is most likely a virus that is effecting the following registry key

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\DefaultConnectionSettings

The only important part of this binary is the first octet of the 0008 line underlined/highlighted below.


0000 00 00 00 00 00 00 00 00

0008 03 00 00 00 00 00 00 00

bit of info on what that octet does;

09 makes it "automatically detect settings" disable proxy and all other LAN settings

03 is most likely what it is set to currently and that is for when proxy is enabled only

0B is when both are enabled but proxy will still take over

05 is when "use auto config script" is enabled

0D is when auto detect and auto config are enabled

07 is when auto config and lan are enabled

0F when everything is enabled

01 when nothing is enabled


Change it to this (only the highlighted part is important leave the rest default)

to make the change when right clicking and editing place your cursor infront of the 09 in the example above backspace once it will delete 03 then type 09 click okay and now your internet will work.


Another known program that causes this issue is "Rocket Tab" you can uninstall it from your add and remove programs list, I've seen it many times on various computers that it installs itself and changes your proxy address preventing you from using the internet at all, after uninstalling you can set your proxy back and it should just work.


Enjoy your internet again.

Edited: 30th May 2016 - Updated ProxyPerUser section as its viable even when LAN settings isn't greyed out.

Luke Vermaas - Fully Qualified IT Technician for DEECD.

197 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
I had windows do an update and then I reset the Internet Explorer settings and everything works great now.

96 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.