internet options html editor

I run Win8; Explorer 11. My question is how to set my html editor to MS Word. The only option showing is Notepad. I have Office 2013 and is downloaded correctly. How do I make this happen?
 

Question Info


Last updated April 2, 2019 Views 10,817 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

 

Thank you for writing to Microsoft Communities.

 

From your issue description it looks that Internet Explorer is failing to recognize Microsoft Word or other applications that you can set as default to open HTML files.

 

I would personally recommend you to use Notepad because it is optimized for HTML files, but you can follow the steps below to set Microsoft Word as a default editor.

 

1. In the start menu type RegEdit and press enter.

2. Navigate to the following registry key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer

3. Create a sub-key named as View Source Editor under “Internet Explorer”.

4. Create a sub-key named as Editor Name under “View Source Editor”. For example, the complete registry key name is now:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\View Source Editor\Editor Name

5. Change Default value of “Editor Name” to Word.exe (to choose Word as default HTML viewer).

 

Note: This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, you can refer to the following steps to back the registry files on the computer:

a) Press Windows and R key to open the run box.

b) Type ‘regedit’ and press Enter from the keyboard.

c) Open the file option on the menu bar.

d) Click on Export and save the file with a name on the desktop.

 

If you want to restore the file, you can do so by double clicking the file that you have saved on the desktop.

 

Let me know if you have any question and update us on the status of the issue.

 

Hope this helps!!

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,


I followed your instructions step by step (with the one difference being that I changed the default value of the Editor Name registry key to notepad++.exe) (see image below), rebooted, but got no results. In IE11, under file, it still says, "edit with notepad'; in the internet Options/programs tab the drop-down box still only lists notepad.


Any idea on what I'm doing wrong? Am I using the wrong registry value type? Do I need to specify the string length? Do I need to add notepad++ to my environment variables?


Seems to me it should work "as is", but I'm in over my head.


Kandi

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've got the same problem. If I right click and choose View Source, it opens Microsoft Word. I DO NOT want to use Microsoft Word. I'd like to use Notepad++ or even Notepad. I followed the steps in this tutorial and it does not work in the least.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've got the same problem. If I right click and choose View Source, it opens Microsoft Word.

Sounds like the opposite one.   E.g.,  I don't think that View Source is what this thread is about.   Use Options, Programs tab and look at the list of programs you have under HTML editor dropdown.  Is the one you want listed there?  Is the default (e.g. the one showing) the one you want to use?  If not change it.  Then, in the Command bar use the Edit button to see if clicking it makes that program open with the source of the page you are in.  That would be opening the default HTML editor (but also give you the option of choosing a different program for editing.)

Ugh.  Word is taking over both File, Edit and View Source?  I think that's new.  So now I will definitely choose Notepad as my default editor in Programs tab and then only get Word optionally via the Edit button dropdown menu.

Oh.  I know what has changed.  The Developer Tools.  There used to be a way of changing the View Source program in there.  In any case, I am sure that there used to be a distinction between View Source and Edit HTML but apparently no longer.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If you are on a 64 bit system you will need to set the Key in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\View Source Editor\Editor Name as the one in HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer is the one for the 64 bit version of IE which is usually not the one you want to use. Windows launches the 32 bit version of IE by default even on 64 bit systems as ActiveX etc don't work with 64bit browser unless they have been compiled as 64bit (and most have not). 

I got it work using the Wow6432 Key. 

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I put the full path to the program I want to use and it's working for me.  Specifically, the data value of the Default Editor Name key is:

C:\Program Files\Notepad++\notepad++.exe

Now when I right-click on a webpage and select 'View Source' it opens right up in Notepad++.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Doesn't work for me. There wasn't a "View Source Editor" in the registry under the wow6432 tree, so I added it and the "Editor Name". But nothing works. Still opens in whatever is selected in "Internet Options/Programs/html editing".

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

OK. Got it working. Had to edit HKCU, not HKLM hive.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

None of the above proposals prevented the default (F12 Dev Tools) editor from being the View Source editor in IE11. I solved it by setting Notepad as the HTML Editor in "Internet Options" -> "Programs" and THEN setting the registry key HKEY_CURRENT_USER\Microsoft\Internet Explorer\View Source Editor\Editor Name to my editor.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This key controls the program launched when you select [view>source code] in the menu.

But Internet Explorer has another selection for Editing, different from this previous one. And this is not controlled by the program, but by windows instead:

You have to navigate to

HKEY_CLASSES_ROOT\.htm\OpenWithList

and

HKEY_CLASSES_ROOT\.html\OpenWithList

Add a new key with the name of the program:  (ex. Notepad++)

New Key: shell

New Key: edit

New Key: command

Default: path of the program (Notepad++) plus %1 ("c:\program files\...." %1)

You have to do this in both trees (.htm and .html)

Restart internet explorer, in order to refresh the options added in the registry, and the new program appears in the list.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.