Internet Explorer 11 slow loading pages it waits too long

Hi,


Ever since I instad windows 8.1 and installed the internet explorer 11, going to websites is very lame.


The its not that the pages are lowing slow. It has to do with connecting to the page, and getting a respond from the server or the page, and on the page tab it always says, "waiting of "web address" to connect", and the pages loads like 1 minute later.


That's too long any thoughts, has this been happening to other people?


Help.

 

Question Info


Last updated March 26, 2019 Views 19,945 Applies to:
Answer

I managed to get things working with IE by disabling Protected Mode. You can find the setting in IE under Tools -> Internet Options -> Security (Tab) -> uncheck Enable Protected Mode. This fixed the slow page loading for me.

Strangely, this setting somehow affected Firefox also. I don't think there is a connection between them but Firefox displayed the web pages in a blink of an eye same as IE after unchecking that box.

Rechecking that option slowed IE down again. Firefox on the other hand, loads the pages quick.

I unfortunately can't find a fix for the other slowdowns. This kind of remembers me of Windows Vista....

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.