IE11 will NOT work in desktop mode on W8.1

Please help!


I have an HP laptop that I purchased back in 2011 with Windows 7 installed, then one year later (in 2012) I upgraded to Windows 8. Ever since I upgraded to Windows 8, the desktop version of Internet Explorer 10 would not even launch properly about 10% of the time. When I went to click on the launch icon on the taskbar to launch IE10, sometimes, I would just get a blank screen and my home page wouldn't even load. To get around this problem, I would have to launch the app version of IE10, then click "View on Desktop," and then it would usually launch it on the desktop just fine.


Now, I have recently upgraded to Windows 8.1 and Internet Explorer 11 and the problem is now MUCH worse. Now, whenever I launch IE11 in desktop mode, it doesn't work about 90% of the time. It just launches a blank screen. I have to keep on closing the window and re-launching the program hoping that it finally loads properly. After maybe re-launching it about 5-10 times, it will finally launch properly to my home page. If I launch it from the app version, then click "View on Desktop," it usually works.


Clearly, Windows 8/8.1 has a problem with launching Internet Explorer 10/11 in desktop mode and I don't know why. I tried disabling ALL add-ons, and that didn't resolve the problem at all. Other browsers, such as Google Chrome work perfectly fine. But I much prefer IE11 over all other browsers....when it actually works!


Please help!

 

Question Info


Last updated August 12, 2018 Views 6,975 Applies to:
Answer

Hi,

Let us follow these methods:

 

Method 1.

Run the Internet Explorer performance troubleshooter.

a) Press the ‘Windows key + W’ key on the keyboard.

b) Type Troubleshooter in the Search box and then press Enter.

c) Select Troubleshooting. Click on View All and select Internet Explorer Performance.

d) Click Next and follow the on-screen instructions. Once this done, restart the computer and check if this helps.

 

Method 2.

You may turn off or disable all add ons and check if this helps to access the website.

Manage add-ons in Internet Explorer: http://windows.microsoft.com/en-in/internet-explorer/manage-add-ons#ie=ie-11

 

Method 3.

You can try to reset Internet Explorer settings to default and check if this helps.

1. Press “Windows key + R” to get the run window.

2. Type “inetcpl.cpl” and click ok to get the “Internet Options” window.

3. Click the “Advanced” tab and click “reset”.

Disclaimer: The Reset Internet Explorer Settings feature might reset security settings or privacy settings that you added to the list of Trusted Sites. The Reset Internet Explorer Settings feature might also reset parental control settings. We recommend that you note these sites before you use the Reset Internet Explorer Settings feature.

 

Reply with the status of the issue and we will be glad to offer our assistance.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.