IE11 crash in some websites with Enhanced Protected Mode enabled

Hi to all


I have a problem with IE11 in some sites with Enhanced Protected Mode enabled in my Windows 8.1 laptop. I have reinstalled Windows 3 times and always experienced the same crashes (Every web page view attempted is displayed for a second or two and then "recovered". This repeats until IE11 gives up and displays a "failed to recover" message). The curious thing about this issue is that the problem is not present in a recent fresh install. I can navigate the problematic sites with no problems for some days later but suddenly the crash reappears and have to reinstall windows to fix it.


I tried all the usual fixes:

  1. Reset Internet Explorer explorer settings (with personal settings checked and unchecked)
  2. Clear the temporary Internet files
  3. Run the Internet Explorer performance troubleshooter
  4. Reset Internet Explorer's security settings
  5. Run SFC/Scannow command (nevers finds damaged files)
  6. Disable/remove the add-ons and check
  7. Use compatibility view in the crashing sites
  8. Uninstalling and reinstalling Internet Explorer 11

The only fix I found is to Disable Enhanced Protected Mode. But It's not a complete fix, only works in desktop IE11. Metro/Modern IE11 keeps crashing because Enhanced Protected Mode is still enabled in the modern environment. The other fix is to disable Protected Mode entirely, but I'm afraid It open the door to malware and infected sites.


I love Internet Explorer. I've been using it as my main browser since IE7 almost exclusively. But this problem is driving me nuts and don't want to use another browser. Please help me...


Thanks in advance.... 

 

Question Info


Last updated September 5, 2018 Views 3,250 Applies to:

Hi,

 

  • Which antivirus program is installed on the computer?

 

Since the issue does not occur after clean install, but after sometime. The issue might be due to some third party software or antivirus program conflicting with Internet Explorer. Try these steps and check if it helps:

 

Step 1: I would suggest you to check if the same issue occur in Safe Mode with Networking on Windows 8.1 PC and check if the issue occurs there as well.

 

 Start your computer in safe mode

http://windows.microsoft.com/en-US/windows-8/windows-startup-settings-including-safe-mode

 

 

Step 2: If issue doesn't occur in safe mode perform clean boot on the computer in normal boot mode. A clean boot helps eliminate software conflicts.

 

How to perform a clean boot in Windows 8.1, Windows 8, Windows 7, or Windows Vista

http://support.microsoft.com/kb/929135

 

Disclaimer: After you have finished troubleshooting, follow these steps from section “How to reset the computer to start as usual after clean boot troubleshooting” to reset the computer to start as usual.

 

Hope this helps. If you need further assistance with Windows, let us know and will be glad to help.

John Rubdy
Forum Moderator | Microsoft Community

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for your quick response.


I'm using the default antivirus in Windows 8.1: Windows defender


I'm going to try to diagnose the problem with safe mode and back here to report any issue.


The software I'm using is this:

  1. Microsoft Office 2013 Home premium (Office 365 subscription)
  2. CorelDraw Graphics Suite X6.4
  3. Adobe Creative Cloud (Photoshop, Illustrator, InDesign, Dreamweaver, Muse, Acrobat)
  4. WinRAR 5.02

Every clean install of Windows I install this software and never gave me problems. The Metro/Modern IE11 crash occurs some days later when I set my computer and load all my software to work.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Tried to check the issue with Safe Mode with Networking and Modern IE11 won't open (It says I can try from another account). IE11 desktop Works fine.


Tried with clean boot and the issue persists with Metro IE11, same "recovered" message again.


Any ideas?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

None of the modern UI apps will work on safe mode this is default by design. To run modern UI you need graphic card drivers and they are disabled by default in safe mode.

 

Turn off hardware acceleration and check:

 

Hardware acceleration uses your PC's GPU to speed up graphics-heavy tasks like video streaming or online gaming. Turning this off might help solve display problems.

  1. Open the desktop, and then tap or click the Internet Explorer icon on the taskbar.
  2. Tap or click the Tools button, and then tap or click Internet options.
  3. On the Advanced tab, select Use software rendering instead of GPU rendering.
  4. Tap or click OK, and then restart Internet Explorer for the changes to take effect.

 

Also See: http://windows.microsoft.com/en-in/internet-explorer/ie-crashes-stops-working#ie=ie-11

 

Hope this helps

John

John Rubdy
Forum Moderator | Microsoft Community

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for your response.


I'm going to try turning off hardware acceleration, but I don't think It would help. If It were a GPU issue, all the pages will crash. I can load very heavy websites with no crash in Modern IE11, but there are other sites that crash and are very simple.


Is it some compatibility issue with IE11 with Enhanced Protected Mode activated? The problem is always present every time I try to log in into any Google Service (Search, Maps, YouTube) in Modern IE11. The browser crashes immediately In the sign in page for Google services. In other sites It simply crashes.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

Since, Internet Explorer 11 is new web browser there might be chances that some websites are not compatible with Internet Explorer. I would suggest you to try turning off hardware acceleration and check if it helps.

 

You may also try updating the latest Graphic card drivers and check.

 

Download and install drivers

http://windows.microsoft.com/en-in/windows-8/all-drivers

 

Hope this helps,

John

John Rubdy
Forum Moderator | Microsoft Community

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.