IE 11 High Memory (RAM) Usage

Hello. I am currently running 4 tabs on Internet explorer and it is using 1GB of RAM.  I have 2 twitch tabs open, a reddit tab and this tab. It doesn't initially use so much RAM when I first open these tabs leading me to suspecting a memory leak problem of some kind. I have tried to reset IE to factory settings but it doesn't work and still uses a high amount of RAM. Is there anyone I can fix this? Thanks in advance,

Matty

Answer
Answer

Hi Matty,

Thank you for the response.

Reinstall Internet Explorer 11 and see if it helps. Please follow the steps below :-

1. Type Turn Windows features on or off in the start search box, hit enter.

2. Now Remove the check mark from Internet explorer 11 and click ok.

3. Restart the computer.

4. Now place a check mark on Internet explorer 11 and click ok.

5. Restart the computer.

And then check if you still face the issue and check with all the available windows updates.

Hope this information is helpful. Please do let us know if you need further assistance with Windows, we’ll be glad to assist you.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hi Vipiny35 and Oldgeek59,

I can understand it is frustrating when things do not work as expected.

I suggest you try the steps below and then, check the issue.

Step 1

To know if it is an add-on problem, start Internet Explorer without add-ons. Refer the steps below to do that.

1. Click Start, and then type Internet Explorer in the Start Search box.
2. Click Internet Explorer (No Add-Ons). Internet Explorer opens without add-ons, toolbars, or plug-ins.

3. Test Internet Explorer to verify that it works correctly.

If the issue does not persist when you run Internet Explorer without add-ons, then clearly the issue is with add-on or add-ons. Proceed to next step to troubleshoot the problem.

Step 2

Now try the steps below to find which add-on or add-ons are creating the issue.

1. Open Internet Explorer and click on the Tools button, and then tap or click Manage add-ons.

2. Disable all the add-ons.

3. Enable each add-on one by one and check the performance of Internet Explorer.

4. Once you find the add-on that is creating the problem, disable it in the Manage Add-Ons window.

You also may refer the article below.

Manage add-ons in Internet Explorer

http://windows.microsoft.com/en-US/internet-explorer/manage-add-ons 

Hope this information helps. Otherwise, please write to us, we will be glad to assist you further.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated February 11, 2020 Views 21,628 Applies to:

Related Forums