Flash Videos - Data Execution Prevention message

Smittychat,
So now my browser closes again when I try to play a video  - presumably a flash video.
This is the error:

Windows Data Execution Prevention detected an add-on trying to use the system memory incorrectly. This can be caused by a malfunction or a malicious add-on.

Other things you can do:

Go online to learn about the Data Execution Prevention (DEP) security feature


I guess it's something to do with lack of support for flash.

Is this correct?

Also my Metro browser and my desktop browser seem exactly the same.  Are they?

When I click on the icon in the Metro view and so some surfing then close the browser down I end up at the desk top not back at start screen.  I say this because i note you've often asked whether I'm in metro mode of desktop mode and they both look/feel exactly the same - unlike when I use IE on my surfaceRT.  Metro mode is distinctly different from desk top.  And all videos play okay on it.


Either way I can't watch quite a number of online videos.  In either the metro or desktop IE.

When I try to download and add the latest version of Adobe flash I get stopped from installing it.

Again is this because of Microsofts desire to not support flash?


I've stopped using IE if I'm going to a sight where I want to watch video as I'm never sure if it will shut me down.  I take it most Youtube is flash as I can't watch anything there. 

well that's not true.  Some of the adds play okay but when I try to watch a posted Youtube  clip the browser shuts down.

 

Question Info


Last updated May 1, 2018 Views 191 Applies to:

Were you prompted to install Flash?


Flash Player for IE is embedded by Microsoft


Reset IE Browser

Tools > Internet Options > Advanced Tab

Press Reset button

Check delete all personal settings

Press Reset

Click Ok

Reboot for changes to take effect


The only difference between how sites behave in the two browsing experiences is plug-in support

http://msdn.microsoft.com/en-us/library/hh920753(v=vs.85).aspx


Tools > Internet Options > Programs Tab

Under Choose How You Open Links

Select Let Internet Explorer Decide

Click Apply, Ok


You should then be back on Metro desktop not Windows desktop


Control Panel > Advanced System Settings

Under Performance, click Settings Button

Click on Data Execution Prevention Tab

Check Turn on DEP for all Programs and Services except those I select

Click Apply

Select Visual Effects Tab

Select Adjust for Best Performance

Click Apply, Ok


Reboot and retry videos












Pat
As a responsible member of the community, please mark the reply that has resolved your issue. Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.