Flash player isn't working in IE 11 windows 8.1

I just upgraded to windows 8.1, and flash player isn't working in the new IE 11. I installed all updates and have checked that I have the most current version of flash installed. But when I test whether flash is working or not (example, by trying to upload facebook photos), it isn't working.


The flash test on adobe's website says I'm not running internet explorer in windows 8 (maybe b/c it's windows 8.1). It works fine in firefox and chrome, but I like the new IE and want to keep using it.


Is anyone else having this problem? And how can I fix it?

 

Question Info


Last updated December 5, 2018 Views 81,680 Applies to:
Answer

I was having the same issue for a long time and finally got this to work. Here's how:


1. Open the website that has Flash content and the one you are having issues with

2. IN IE, go to Settings, then select the "Compatibility view settings" menu

3. Add your website to the list; make sure the two check boxes at the bottom are checked

4. Click OK and everything should be fine

32 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

Jdmayer, 

I got this fixed by registering the flash.ocx file. 

try the below and check if it works for you. 

regsvr32 c:\windows\system32\macromed\flash\flash.ocx

Copy the above onto a notepad and save it flash.bat and run it as an administrator by right clicking on the file and select run as administrator. 

Try and open the website that you were unable to open so far. 

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.