Slow to go back in IE10 in Win8 RT on Surface

Swiping to go back a web page in IE10 (modern ui) on the Surface is slow. Going back seems to force a reload of the page, meaning a couple of seconds delay. This is annoying and unnecessary. How can I stop this "reload on going back" behavior?

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

this is also driving me mad. I bought a surface 2 for its PowerPoint support but this browsing issue will drive me to a different product for al other uses. well cone Ms, a good lesson in how to lose customers


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just saw another post that fixed this - in desktop mode, go to tools -> Internet Options -> Browsing History -> Settings, and where it asks when to check for an updated copy of the web page, change it to Every time I start IE or never.


Fixed it for me, works much better now

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just saw another post that fixed this - in desktop mode, go to tools -> Internet Options -> Browsing History -> Settings, and where it asks when to check for an updated copy of the web page, change it to Every time I start IE or never.


Fixed it for me, works much better now

Nope.  Tried it - doesn't make any difference in Metro / touch mode.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

doesn't make any difference in Metro / touch mode.        

In MUF IE you can use the "Flip ahead" feature but for some bizarre reason it only shows as an option in Options Advanced tab.   Try turning that off?  It isn't found when I look for help so I'm wondering if it is an option best left forgotten.   <eg>


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm actually on my third Surface RT (sent the first one to customer support for a broken screen glass; returned the second one I got in return because everything that was supposed to be white got displayed in pink and sound was still audible even with the volume set to zero; third one so far holding up ok), but all three have the aforementioned loading problems with the metro IE. The loading problem was persistent even fresh out of the box, after updates to Win 8.1 and no programs, apps, or other files installed. This counts for all devices.


MSFT, please prove to me that you actually do invest into your product life cycle and delegate some programmers to fix this problem (which has worked in all previous desktop version so far). And if you are kind enough for that, please consider looking at your bread and butter product MS Office which with every version seems to become less user friendly with every version. While I understand that things like reducing clicks for the user to reach a command might be too much to ask of a "lean" development unit, making one version of your program to work as quickly as the other probably has some benefits (keeping ground in the browser war, establishing Windows on the tablet market, giving customers reason not to switch to another product...)



Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just saw another post that fixed this - in desktop mode, go to tools -> Internet Options -> Browsing History -> Settings, and where it asks when to check for an updated copy of the web page, change it to Every time I start IE or never.

Fixed it for me, works much better now

Nope.  Tried it - doesn't make any difference in Metro / touch mode.

I'm in the same boat. EXTREMELY frustrating!

Come on MSFT. Web browsing has to be the most important reason for customers to buy a tablet and the experience here is not good. I have to wait many seconds for a forced refreshed even after changing the settings multiple times. I also think it has to do with slow ad displays which are on every webpage these days but I don't see this frustrating delay on my netbook or kindle.

And to the lame Microsoft response, it is on EVERY PAGE, ALL THE TIME, even after changing ALL SETTINGS.

Please address this issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I agree.  It makes the surface very frustrating to use while browsing.  

I have tried everything recommended here and elsewhere.  

There is something else wrong with how web pages are handled.  I have even gone back a page when not connected to the internet.  (after it was to load some pages of course)  The same issue.  Pages that are large take a looong time to finish "loading".  Pages that are small/simple take much less time.  In both instances they are dimmed out and cannot be browsed even though it appears 95% or all of the page is loaded.  Happens for every page going forward or backward just loading from the cache.

So there must be something with the way the browser fetches from the cache or with the way the machine/os handles caches that cause this delay.  It would be nice at least if the user could browse around on the page while it "finishes."

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This appears to be significantly improved in the latest 8.1 Update, now only taking a second rather than several - a huge improvement.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Me toon. Verg annoying. On iOS is Worms perfectly fine. Must Be improved by Microsoft.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Still getting major hangs. Tried disabling the recommended features etc. still having a refresh delay of 1-5 seconds on every page and timeout hanging on 20%. Seems to be proportionally related to amount of content on a page that comes from other domains/servers.

Leave it to MSFT to screw up the simple task of caching data. Divest/separate IE from the desktop/OS- it's never been a winning proposition guys: think of the 100's of millions in legal fees (US and EU) and developers you've spent to defend and patch bugs/vulnerability that can all be traced back to this stupid MBA driven (rather than MSE/technical) decision.

At some point I'm going to have to switch to Chrome or Firefox. When I do the first question will be why do I even need a MSFT OS based platform? Even Safari for the Apple toys works better. Come on, man!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 9, 2018 Views 4,451 Applies to:

Related Forums