Question
  • This thread is locked from future replies
168774 views

Internet Explorer 10 "this page can't be displayed"

Ravens 2K asked on
I purchased a new Dell computer last week. It was pre-installed with Windows 8 and Internet explorer 10. I am unable to browse the Internet with IE 10. I can browse the Internet with other browsers like Firefox. Every time I open IE 10 I get the error message

This page can't be displayed
  • Make sure the web address http://google.com is correct.
  • Look for the page with your search engine.
  • Refresh the page in a few minutes.
  • Check that all network cables are plugged in.
  • Verify that airplane mode is turned off.
  • Make sure your wireless switch is turned on.
  • See if you can connect to mobile broadband.
  • Restart your router.

The "Fix connection Problems" button cannot correct the issue. It does not matter what address I enter in the URL. If I open "Control Panel" and check network connections, it states I am connected to the Internet. I checked the McAfee Firewall settings. It indicates IE can reach  the Internet. I even disabled the Firewall for a few minutes to see if it was blocking access. I still could not browse with IE 10.
320 people had this question

Abuse history


The answered status icon Answer
Equinox64 replied on

I have the exact problem. The suggestions above did not work.  The metro app part of IE works, but not the desktop version.  In addition to the above things, I have checked to make sure there is no proxy settings, temporarily turned off the firewall, tried uninstalling IE, which really just disabled it, ran system file checker (sfc /scannow) and still no connection.  If I click setup connection under the connection tab, it says "You are already connected to the internet" .

I am out of ideas.

Any help appreciated.

I have got exactly the same problem. I cant even open Microsoft.com which makes looking for a solution "challenging".
I tried the following solution that worked for me. Hope it helps.

I found this on another thread. Worked for me. I now have IE10 in desktop.

 

1, Open IE on desktop (not metro), press the setting icon on the right top and open "internet options"

2, open "Advanced" tab, locate the "security" section among all the settings, and enable "enhanced protection mode",

3, reopen IE and it will be fine. But in my case, all the third-party extensions will stop working.

74 people found this helpful

Abuse history


The answered status icon Answer
SpataWin replied on

Buzzmag, the AppContainer network restrictions are sensitive to your network configuration. If your network as configured as a Private Network the Firewall considers your router not part of a public network and so it is unable to contact it and the IE under Metro doesn't works. To solve the issue you have to set manually the preferred and alternate DNS addresses (I used Google DNS addresses: preferred = 8.8.8.8, alternate 8.8.4.4).

Alternatively you can disable the network restriction by reconfiguring your network settings. First, use the sidebar's context menu to tell Windows to “forget” your network connection. Then, re-establish it as a “public” network. As a result the Firewall will consider your router part of a public network and thus AppContainers are freely able to contact your router address (192.168.1.1) and thus the privateNetworkClientServer capability is not required to contact local / non-routable addresses.

I hope that can help you to solve the issue.

Best regards

6 people found this helpful

Abuse history


progress