Internet Explorer 10 crashes

I have just upgraded to Windows 8 Pro from Windows 7 Home Premium. Internet Explorer 9 was the default browser in Windows 7 and was working fine. 

I can't open Internet Explorer 10 at all (normal mode, admin mode or with add-ons disabled). Both the Metro & Desktop versions don't work. It just crashes with an error - A program caused Internet Explorer to stop responding. I have to end it using Task Manager.

I have tried all of the fixes - reset IE to defaults, disabled add-ons, etc. But nothing works.

I created another user account. Now the metro version works but the desktop version still crashes with the same message above.

I am using Google Chrome as the default now.

How do I fix this issue? I am in Australia and as of date only the upgrade version of Win 8 Pro is available. I would like to avoid a total reinstall (unless it is the only option) as I will need to install Win 7 again and then upgrade to Win 8 Pro.

Many Thanks.

Regards.
 

Question Info


Last updated May 15, 2018 Views 15,649 Applies to:
Answer
Answer

Issue has been resolved!!!!

 

I went to device manager -> right clicked on my video card -> scan for driver updates. Windows found an updated driver, downloaded and installed.

 

IE10 works perfectly in both metro and desktop. Enabled as default browser.

 

Happy Camper.

 

Thanks for your help everyone. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.