Get the Internet Explorer script error which says "Access denied error for LocalStorage"

Original title: IE10 - Javascript Access denied error for LocalStorage

 

 

Hi

 

I am facing an issue with IE10 on Win8Pro that impacts several websites. End-user impact is a broken functionality, i.e. click on a button that does nothing.

The sites works fine with another browser, works fine using "InPrivate" mode, and even works fine on another Win8Pro computer using IE10. So this is definitely a setting on the one particular computer.

Looking at the F12 developer tools, it shows an error message SCRIPT5: Access is denied. It seems to be unhappy when the Javascript code tries to access LocalStorage.

 

I have cleared local cache, i have reset IE10, I have even uninstalled/reinstalled it using the "add/remove features" function of Win8, but i still have the problem.

 

Is there a setting somewhere to enable/disable the use of the LocalStorage functionality ? Why/How has this been disabled on that particular computer (it used to work before) ?

 

Thanks

 

For further reference on the problem :

 

The exact same issue has been reported (with more details) at these locations :

http://stackoverflow.com/questions/13102116/access-denied-for-localstorage-in-ie10

https://drupal.org/node/1849764

 

Examples of impacted websites :

outlook.com

azure portal

Samsung support website

...

 

 
Question Info

Last updated August 10, 2018 Views 26,108 Applies to:

Hi Greg,

 

Thank you for choosing Windows 8 and thanks for providing us an opportunity to assist you.

 

Based on the description provided, it looks like you are not able to access website in Internet Explorer.

I have a couple of steps which should assist you with this issue.

 

Method 1:

Try to Use Compatibility View in Internet Explorer and check

http://windows.microsoft.com/en-US/internet-explorer/use-compatibility-view#ie=ie-10

 

Method 2:

 

How to troubleshoot script errors in Internet Explorer on Windows-based computers. Please follow the instructions’ mentioned below.

 

Step 1: Disable script debugging

 

a) Open Internet Explorer, On the Tools menu, click Internet Options. If you can't see the Tools menu, press Alt to display the menus.

b) On the Advanced tab, click to clear the Display a notification about every script error box, and then click OK.

 

To turn off the Scripting Debugger in Internet Explorer 10, follow these steps:

a  Open Internet Explorer On the Tools menu, click Internet Options.

b. On the Advanced tab, click to select the Disable script debugging box, and then click OK.

 

Step 2: Verify that Active Scripting, ActiveX, and Java are not being blocked by Internet Explorer


Active scripting, ActiveX, and Java are all involved in shaping the way that information is displayed on a webpage. If these features are blocked on your computer, this may disrupt the display of the webpage. You can reset your Internet Explorer security settings to make sure these features are not blocked. To do this, follow these steps:

a. Start Internet Explorer.

b. On the Tools menu, click Internet Options. If you can't see the Tools menu, press Alt to display the menus.

c. In the Internet Options dialog box, click the Security tab.

d. Click Default Level.

e. Click OK.

Note ActiveX controls and Java programs are turned off in the High security level in Internet Explorer.

 

 

Step 3: Remove all temporary Internet files.

Each time you open a browser to view a webpage, the computer stores a local copy of that webpage in a temporary file. If the size of the temporary Internet files folder becomes too large, some display problems may occur when you open WebPages. Periodically clearing the folder might help to resolve the problem.


To remove all the temporary Internet-related files from your computer when you use Internet Explorer 10 or Internet Explorer 9, follow these steps:

1. Start Internet Explorer.

2. On the Tools menu, click Internet Options. If you can't see the Tools menu, press Alt to display the menus.

3. Click the General tab.

4. Under Browsing History, click Delete.

5. In the Delete Browsing History dialog box, click to select the following check boxes, and then click Delete:

i. Temporary Internet Files.

ii. Cookies.

iii.  History.

6. Click Close, and then click OK to close the Internet Options dialog box.

 

Hope this helps. If you have any more queries related to Windows feel free to post here at Microsoft Community.

Ravinath P
Forum Moderator - Multiple Forums

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is apparently a permissions issue, since when I run IE as Admin or disable Protected Mode the issue disappears.

However, I cannot force my users do that, and I cannot change a 3rd party script that I run on my site.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

Did you ever find out what causes this? I am experiencing the same issue.

Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the exact same problem

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.