Drop-down list closes immediately on most web sites when opened in IE10 with Window8 on ACER Iconia W700 tablet.

I have a ACER Iconia W700 tablet running Window 8 and IE10. Whenever I try to open a drop-down menu on most web sites (bestbuy, Lowes etc) to select an item in the drop down list, it closes right away before I get a chance to select the item in the list. I am not sure if anybody else has seen this problem on the tablets (Touch) version of the IE10 with Window 8 and is this an issue with IE 10 or something else. Any idea to fix this would greatly help.   

Hi,
Thank you for your post and giving us an opportunity to assist you. I understand that you are facing issues with drop down menus on Internet Explorer.

 

Please answer these questions so I can understand the issue better.
1.On which version of Internet Explorer are you facing this issue?
2.Is the issue confined to just drop down menus?
 
You can try these troubleshooting steps to check if the issue gets resolved.

Method 1:Run the Internet Explorer Performance troubleshooter.
a)Swipe in from the right edge of the screen to show the Charms bar.
b)Tap "Search" and type "Troubleshooting" and tap "Settings" and open the "Troubleshooting"result.
c) Tap "View All" on the left pane and run the "Internet Explorer Performance" troubleshooter.
 
Method 2: Delete the browsing history.
a)Swipe in from the right edge of the screen to show the Charms bar.
b)Tap "Search" and type "Run" and open the "Run" result.
c)Type "inetcpl.cpl" and tap "OK".
d)Under Browsing history, Tap "Delete".
e)Select all the check boxes, and then tap "Delete".
 
Method 3:Check if the issue exists in No Add-ons mode.
a)Swipe in from the right edge of the screen to show the Charms bar.
b)Tap "Search" and type "Run" and open the "Run" result.
c)Type "iexplore.exe -extoff" and tap "OK".
d)Check if the issue exists.You can then go to "Tools" and "Manage add-ons".
e)Select an add-on in the Name list, tap "Disable", and then tap "OK".
f)Repeat step e until you identify the add-on that is causing the problem.
When you want to enable an add-on, tap an add-on in the Name list, and then tap "Enable".
 
Method 4: Reset Internet Explorer.
a)Swipe in from the right edge of the screen to show the Charms bar.
b)Tap "Search" and type "Run" and open the "Run" result.
c)Type "inetcpl.cpl" and tap "OK".
d)Tap ‘Advanced tab’and ‘Reset’ and tap ‘OK’.
 
Note: Please note that running Reset Internet Explorer Settings will reset all user-defined settings including those set by installed extensions, toolbars and other add-ons to IE Defaults.This includes all Security, Privacy and Zone settings. Also this will clear browsing history,delete all temporary Internet Files, cookies, form data and especially all stored passwords.
 
Feel free to use the forum in the future for any other Windows questions you may have.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks ajeshdsouza for the helpful hints. I have tried everything you mentioned in your reply but nothing seem to fix the problem. The issue is still the same i.e. drop down list opens for a couple of seconds after I touch the down arrow on a button in a web site such as Lowes.com and then the list closes automatically before I am able to select any item in the list. The version of IE10 I am running is:

Version - 10.0.9200.16466

Update Version - 10.0.1 (KB2761465).

 

Thanks for your help. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi hkn579,

 

Thanks for getting back to us.
 
Did the drop down menus work fine earlier?
 
Lets disable and enable Internet Explorer and then check if the issue persists.
a)On the Start screen, type "View Installed Updates" , tap "Settings" and then open the result View Installed Updates.
b)On the left pane, tap "Turn Windows features on or off".
c)Uncheck "Internet Explorer 10" and tap OK to remove it.
d)Restart the device if prompted.
e)Follow a-b and this time check "Internet Explorer 10" to reinstall it.
Check if the drop down menus work now.
 
Note: Please remember that this method will reset all user-defined settings including those set by installed extensions, toolbars and other add-ons to IE Defaults.This includes all Security, Privacy and Zone settings. Also this will clear browsing history,delete all temporary Internet Files, cookies, form data and especially all stored passwords.
 
Let us know what happens.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ajeshdsouza,

I followed your suggestions to turn off the IE10 features and then turn them back on and test the Drop-Down list problem. I did that and there is no change in the Drop-Down list behavior and the problem is still unresolved.

I looked at other blogs and forums to see if anybody else is facing similar issues and I see this as a widespread problem with IE10 and Window 8 RT on Surface tablets as well as Window Phones. See the link below for more info and details. It seems the Microsoft needs to put some extra effort in resolving this problem as soon as possible.

 

http://forums.wpcentral.com/windows-phone-8/202545-ie-10-drop-down-menu-problem.html

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also have this problem with IE 11 and Windows 8.1, on Yahoo Finance and other applications as well. When I switched to Chrome the problem went away.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated September 2, 2020 Views 6,228 Applies to:

Related Forums