No pictures - but Black Box with White X

No pictures - but Black Box with White X

Lately I can't download images in websites - for example the weather channel and others (blank windows, no images, but black box and white X.)

But not all - other websites give me no problem

 

Same on Facebook - can't upload images, but works sometimes.

Then I get also the black box with the white X

 

E-mail works fine, images and all (Windows Mail)

It does NOT show images though until I click ok or accept sender as safe

 

- I have the newest Flash Player

- IE10 > tools > options > privacy is set to default (medium)

-               "                      > security - default / medium high - Protected Mode for Internet = ON (default)

- Control Panel > Java > is enabled

- Manage Addons > everything Flash is enabled

- Manage Addons > everything Java is enabled

 

Windows 7, 64 bit

IE 10

Bitdefender 2013, all set to default (any suggestion here-firewall / security settings...?)

Bitdefender has a feature = Safego - to prevent spam and viruses through facebook / twitter. I have this set to ON.

 

Again - only on some websites - otherwise machine / internet works fine

 

Thanks

|
Answer
Answer

I fixed the problem - not really though

Get rid of IE and switch to Chrome - Done!
All works !
I like the favourites layout of IE better, but
now I'm a Chrome man - thats it

Lots of complaints about IE about this issue

I had the dreaded white x in a black box issue on a single website on several workstation on my network.  I had one computer with IE11 that the site worked, and I had other workstations on the same network that did not work. Both working and non-working workstations had Windows 7 Pro installed.  I tried all the normal fixes to no avail.

I broke my troubleshooting down to one working and one non-working workstation.  I double checked if both workstations were in the same OU on the network...which meant that the same Group Policies were being applied to Internet Explorer. So I tried a different browser...Chrome did not work either on the broken computer.  Then I tried Firefox, and the pictures on the website populated.

So now I know that it is possible for the website to populate the pictures on our network on this particular workstation...but I needed to get IE11 to work.  I right clicked on the picture to find out the URL that the picture was pointing to. It was pointing to HTTPS, while the website was an HTTP website.  This is a clue.

There is mixed content on this webpage...but changing group policy to "allow mixed content" did not fix the issue either.  When I copy the link and pasted it in the address bar of IE (on broken workstation), and hit enter,  I get the "untrusted site, continue not recommended page." When I hit continue I was able to see the picture that I should have seen on the website.  Now it is getting more interesting.  Note: It is important to remember that on both computers, getting to the initial website did not invoke the "untrusted website, continue not recommended" page.  I tested the link URL on the working workstation and I was able to go straight to the page with the picture without the warning page (Continue not recommended) coming up first.  So now, the workstation that is not working does not seem trust the HTTPS picture links...which is shown by the white x in a black box. 

In IE9, if there was a case of mixed content and there was untrusted content on the webpage, there would be a banner that explains that there is untrusted content on the webpage...Do you want to continue or show content?  If you click continue or show content you would see the picture(s) or content that was not trusted.  I tested this on one of the broken workstation by downgrading IE11 to IE9.  In IE11, there is no such banner so you have to fix the certificate issue to see the pictures/content.

So I compared the certificates that both workstations were using and found most of the same information except that the root certificate was not showing under the certificate properties "Certification Path" tab on the workstation that was not working. So I exported the IE root certificate from the workstation that was working and imported the root certificate into the workstation that was not working.  You can do this through IE/Internet Options/Content tab/Certificates/Trusted Root Certification Authorities tab. I choose all the default settings through the exporting wizard.  You may have to make sure the missing certificate is going to be imported into the correct location when importing (in my case "root").  So now...the site is working as it should in both IE11 and Chrome.

The key area that assisted me was on the "Certification Path" tab within the certificate properties. In my case, the root certificate was not showing on the machine that was not working.  Another Note: Import the certificate while the user that needs the website to work while they are logged in. 

82 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated June 8, 2021 Views 77,255 Applies to:

Related Forum