ie 10 in win7ult64 won't open

c:\Program Files(x86)\Internet Explorer\explore.exe     Attempt to access invalid address.  and then do I want to remove from start menu.  The install shows a successful installation.
 

Question Info


Last updated May 15, 2018 Views 5,720 Applies to:
Answer
Answer
c:\Program Files(x86)\Internet Explorer\explore.exe     Attempt to access invalid address.  (...)  The install shows a successful installation.            

 

On our Windows 7 Pro 64-bit SP1 systems I solved the "invalid address" problem by removing the

 

 dword value "MoveImages"

 

from the following Windows registry key:

 

 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

 

After that I was able to start IE10 without errors.

 

( Thank you Marcus Jaken for pointing me in the right direction: http://cloudsurvivalguide.com/?p=564 )

 

"MoveImages" seems to be related to "Address space layout randomization" ( http://en.wikipedia.org/wiki/Address_space_layout_randomization#Microsoft_Windows ).

 

For analysis I have checked some of our earlier Windows 7 installs:

  • On two different Win7 installs without "MoveImages" we could start IE10 without error.
  • On several Win7 installs with "MoveImages" equal to 0x00 we got an "invalid error" when starting IE10.  After removing "MoveImages" we could start IE10 without error.

We suspect that running EMET ( http://support.microsoft.com/kb/2458544/en-us ) caused the creation of the "MoveImages" dword in the registry.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hi,

 

Thank you for posting your query in Microsoft Community forums.

 

I understand that you are unable to open Internet Explorer 10 in Windows 7 computer.

 

I would suggest you to follow the path given below to open Internet Explorer.

 

c:\Program Files(x86)\Internet Explorer\iexplore

 

Step 1: You can also try opening Internet Explorer by follow the steps given below.

 

a)      Press Windows key + R,

b)      Type iexplore.exe

c)      Click on Enter.

 

Step 2: Also follow the step to Pin a program in Start menu.

 

a)      Open C drive, Select Programs files (x86) folder.

b)      Open Internet Explorer folder.

c)      Right click on iexplore and select pin to Start menu.

 

Also try launching internet Explorer in no add-ons mode.

 

Follow the steps given below.

 

a)      Click on Start, Select Run.

b)      Type inetcpl.cpl

 

Also refer to the article given below.

 

Manage add-ons in Internet Explorer

 

http://windows.microsoft.com/en-us/internet-explorer/manage-add-ons#ie=ie-10-win-7

 

Also refer to the article given below.

 

Pin a program to the Start menu

 

http://windows.microsoft.com/en-us/windows7/pin-a-program-to-the-start-menu

 

Hope the information was helpful, if you have any further queries or any queries related to Windows, feel free to post. We will be glad to assist you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.