why don't I have the option to "continue to website (not reccomended)" when I encounter a website with a certificate error?

I have recently installed ie 9.0.1 and when trying to logon to my works website I no longer have the option to ignore the certificate error and continue to the site. I am running Vista 32 bit in a home environment. My clock and date are correct.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

 

Method 1:

I would suggest you follow the steps below and check if it helps.

a.     Type inetcpl.cpl in the start search box.

b.    Click on Contents tab.

c.     Click on Certificates.

d.    Click on Trusted Root Certification Authority tab.

e.    Select the website name and click on Remove.

f.      Restart Internet Explorer & try to access the website.

 

Method 2:

 

I would suggest you to try to open the webpage in Compatibility mode. For more information about Compatibility View, see How to use Compatibility View in Internet Explorer 9.

 

Also, Refer:

Certificates: frequently asked questions

http://windows.microsoft.com/en-US/windows-vista/Certificates-frequently-asked-questions

Rohit S

12 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks for those tips but I can't find a certifiacte for the website and the webpage doesn't offer compatability view.

 

I know the site has a certificate error, my Network manager assures me everything is fine . I just want the option to continue to the site.

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Kilgore

 

If your Admin says its ok why would you still want to see certificate errors? There is that saying "If it isnt broke dont fix it". But to answer your question if Internet Explorer detects certificate errors it will be the first to let you know.  Hope that helps some.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

in my opinion, ie9 is losey in certificate management. 

 

perhaps it is an over jealous feature or faulty or requires a configuration panel to fine tune it.

 

in any case, you might try using FireFox browser, since it's certificate handling is much better than ie9.

Status - Off line

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Kilgore

 

If your Admin says its ok why would you still want to see certificate errors? There is that saying "If it isnt broke dont fix it". But to answer your question if Internet Explorer detects certificate errors it will be the first to let you know.  Hope that helps some.


I'm having the same problem (over a year later, depressing).  I'll add that Firefox and Chrome don't have this issue, so my suspicion is that most people are just abandoning IE.

 

Way to go Microsoft.

 

Anyway, to my point:  I think you misunderstood his (and my) issue.

 

IE doesn't even list the "Continue to this website" option.  All it gives us is "Click here to close this webpage".  There is no compatibility view available.

 

In my case I'm trying to connect to a vSphere self signed web client.

 

It's not just a cosmetic error that the certificate is broken (like with Chrome and Firefox), it's that there is no (known) mechanism to ignore it and continue (with the cosmetic error I could accept.)

 

I really have to emphasise how much it bothers me when Microsoft hamstrings it's products like this to protect end users from themselves.  I'm sure there's some cryptic way to disable this, and I'm pretty sure that's what the original question was.

 

If anyone can answer how to re-enable the continue to website (not reccomended) prompt in newer IE browsers, I for one would still like to know.  For better or worse, I TRY to stay loyal and use Microsoft products.  And in this instance they're forcing me to use another browser.

60 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hey,

Check out the link below.  I was running into this issue as well.  I think it was related to this update: "This advisory announces that the use of RSA certificates that have keys that are less than 1024 bits long will be blocked."

The symptom (for me) was that IE acts like it can't even connect to the site, no mention of a certificate issue at all.

http://support.microsoft.com/kb/2661254


You can use the following command to set the minimum RSA Public Key Length to whatever you need, just replace 512 with the minimum length you require.

certutil -setreg chain\minRSAPubKeyBitLength 512

-Henry

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Does anyone understand what the issue is here. Every solution is for a different problem than was originally presented. The OP, one other poster and myself have this issue. Up until recently, for me, when you went to a site that had a bad certificate (expired, no certificate, etc) IE gave you the choice to stay away which was always listed as the recommended action or ignore the warning and go to the site anyway ("not recommended"). This comes up a lot for IT people because you may have appliances on your network that you manage with SSL but you don't want to bother buying and maintaining a certificate for a device that is on your local network and is your device. It recently started happening with me when I mistakenly allowed Windows Update to install IE10. I thought that it must be a feature of IE10. However the OP had this issue with IE9 and I have another instance of IE 10 on another computer that works like I expect. I am protecting that machine from updates with my life. It is pretty sad that I have to do that, and somewhat risky.

 

Is there a setting in IE that I can't find to change this behavior? I want the ability to ignore certificate warnings and go to the site anyway just like I have been able to do for the last 15 years. By the way, I am configured to use compatibility mode for all websites.

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Right-Click Internet Explorer (IE) Icon, Select "Run As Administrator"  Now option should appear to "Continue to this website (not recommended)."

10 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Does anyone understand what the issue is here. Every solution is for a different problem than was originally presented. The OP, one other poster and myself have this issue. Up until recently, for me, when you went to a site that had a bad certificate (expired, no certificate, etc) IE gave you the choice to stay away which was always listed as the recommended action or ignore the warning and go to the site anyway ("not recommended"). This comes up a lot for IT people because you may have appliances on your network that you manage with SSL but you don't want to bother buying and maintaining a certificate for a device that is on your local network and is your device. It recently started happening with me when I mistakenly allowed Windows Update to install IE10. I thought that it must be a feature of IE10. However the OP had this issue with IE9 and I have another instance of IE 10 on another computer that works like I expect. I am protecting that machine from updates with my life. It is pretty sad that I have to do that, and somewhat risky.

Is there a setting in IE that I can't find to change this behavior? I want the ability to ignore certificate warnings and go to the site anyway just like I have been able to do for the last 15 years. By the way, I am configured to use compatibility mode for all websites.

I have this issue as well.  However, Henry UM's answer is correct.  Issue that certutil command above, then restart the "Cryptographic Services" service from the Services MMC snap-in.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

If you are launching from a pinned site or desktop shortcut you don't get the option to continue.   I got around that by creating a shortcut to IE on the desktop with 'run as administrator' privileges and passing the website in the command line.  Like "C:\Program Files\Internet Explorer\iexplore.exe" https:\\192.168.0.1

If I browse to https:\\192.168.0.1 in IE and then drag a shortcut to the desktop it will not work and will not give an option to continue.

10 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated April 11, 2021 Views 30,004 Applies to:

Related Forum