Why AM I seeing something after http://www.msn.com/

Every time I open my home page now I see http://www.msn.com/?pc=EUPP_ instead of just msn.com which is what I have my homepage set to?And it's supposed to be protected from changing,and I still get warnings if I try to change it back to msn.com because of this BS address!!! I already had it set to msn.com in both Internet options and Advanced System Care 8.4 pro!The warning comes from ASC 8.4 not from IE11.I never changed it in either and it never changed in ASC,because I check it every time I run the sucker just to make sure!!!

If I use a different browser like Chrome or Opera instead of IE11 on Windows 10 and 7 before I upgraded I show only msn.com!!! Is this some kind of browser redirect? Because if I take out the ?pc=EUUP my page loads much faster and I'm signed in(which I had done earlier) on the former I had signed in and have not cleaned my chache but it wants me to sign in.When I do,instead of actually having to sign in it goes back to msn.com?=Eupp right away,If I do sign out then back in it does not ask for my two tier authentication I still get this address in my URL box!

If I have a browser redirect virus,why aren't my other 3 browsers affected as well? And Superantispayware misses it,which it has never missed one in the past!!!

I have Edge;of course,IE11 from when I had Windows 7 but not the 64 bit version I installed on 7 it's now the 32 bit version.I also use Chrome and Opera as well but this problem is only occurring in IE11. I have reset it yet I still get this extra bit of address,although it may vary.

I just reset IE11 and will have to come back after I restart my PC to add any more info...

 

Question Info


Last updated June 13, 2019 Views 13,693 Applies to:
Answer
Answer

Hello Benjamin,

Thank you for contacting Microsoft Community.

I understand the inconvenience you have experienced.

Let me confirm that the URL link http://www.msn.com/?pc=EUPP_ is safe and a valid MSN link. The extension part of the URL is automatically added as part of site redirection.

With regard to USB stick, since you're able to see the USB device, I suspect the problem lies with the OS configuration. Suggest you to cross check the USB stick with some other PC to see where the problem lies.

I appreciate your cooperation in this regard.

Keep us posted if you require further assistance.

97 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.