Login to Suddenlink account or online email issue

When attempting to login to my account or email on the Suddenlink.com webpage or start Suddenlink.net as homepage, I get a "There's a problem with this website's security certificate". Suddenlink tech support said don't think it's there problem.

I've reset my modem and router. I've cleared the cache a number of times. My Outlook 10 works fine and retrieves/sends email as it should. 

Hi Lee,

To better assist you,  we would like to know if you have tried accessing the web page to a different web browser?

You may also follow these steps on how to uncheck the Check for server certification revocation under Internet Options in Internet Explorer:

  1. Open Internet Explorer.
  2. Click the gear icon in the upper-right corner of the screen.
  3. Select Internet Options.
  4. Click  the Advanced tab.
  5. Under Settings, locate and uncheck the Check for server certification revocation box.
  6. Click Apply, then OK.

Looking forward to your reply.

Regards.

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Lee,

there is a problem with the way suddenlink.com has been programmed....

before you change any IE settings....

compare these two links to the site

https://suddenlink.com (shows certificate error)

and

http://suddenlink.com (does not show certificate error)

Probably, you have added the website to your IE Trusted Sites list and IE is always using the https protocol....

Tools>Internet Options>Security tab, click "Reset all zones to default"

then

Click the Trusted sites icon, 'Sites' button, remove

suddenlink.com or *.suddenlink.com or authorize.suddenlink.net or suddenlink.net or *.suddenlink.net

from your list of trusted sites. Save your changes. (generally you should not add 'public' web sites to your Trusted Sites list. the secure protocol (https) works (viz your data is encrypted) in any website in any IE security zone.

then

Select the General tab of Internet Options and make sure your link for suddenlink.com homepage is using the http protocol and NOT the https protocol.

If you have already changed the "Check for server revocation" option on the Advanced tab of Internet Options change it back to your original setting.

Regards.

suddenlink.com and suddenlink.net are Amazon companies.

Rob^_^ wang'you

7 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated November 25, 2020 Views 9,546 Applies to:

Related Forums