OWA S/MIME Control in Microsoft EDGE

Does anyone know of a fix to implement the OWA S/MIME control in Microsoft Edge browser?  So far I can't even see any of the same options that would allow me to use it as a plug in.

***Post moved by the moderator to the appropriate forum category.***

 

Question Info


Last updated September 14, 2019 Views 28,338 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Thank you for being part of the Windows 10 family.

Sorry to know that you are facing issues with the Windows 10.

In order to help you better, please provide the information:

1. When you say that "implement the OWA S/MIME control in Microsoft Edge browser", what are you trying to do with it?

2. Have you tried to check with the Internet Explorer present on Windows 10?

To find Internet Explorer in Windows 10. Refer to the below steps.

1. Tap on Windows Key and click on Search bar.

2. Type "Internet Explorer and click on it.

3. Check if you are able to use OWA S/MIME control .

Reply with the information, so that we can assist you better.

Get back to us for further assistance on Windows, let us know and will be glad to help.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thank you for being part of the Windows 10 family.

Sorry to know that you are facing issues with the Windows 10.

In order to help you better, please provide the information:

1. When you say that "implement the OWA S/MIME control in Microsoft Edge browser", what are you trying to do with it?

2. Have you tried to check with the Internet Explorer present on Windows 10?

To find Internet Explorer in Windows 10. Refer to the below steps.

1. Tap on Windows Key and click on Search bar.

2. Type "Internet Explorer and click on it.

3. Check if you are able to use OWA S/MIME control .

Reply with the information, so that we can assist you better.

Get back to us for further assistance on Windows, let us know and will be glad to help.

To he more specific, I'm using the s/mime control for smart card security.  Yes, I did notice that it still works in Internet explorer, but it just seems odd that it's working in a browser that should be on its way out, and not on its successor.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

To add to cjake88's question/Nyima's response, the S/MIME controls works in IE11 just as well as Windows 10.  However, if I access a webpage that uses the smart card for authentication, I am required to open the page in IE if I would like to use a digital signature or message encryption.  Preferably, these functions would be available in Edge and we wouldn't have to switch to IE.

Given the amount of federal agencies and users that use PKI, I would be surprised if we only have the workaround and no solution.  Certainly does seem like a step backward, if indeed this is the case.

Joe

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I concur with Joeimp.  As a DoD contractor I am required to use DoD email and constantly receive secure emails.  Ability to use smime or equivalent is a requirement for DoD OWA.  Edge not much use if can't use DoD email.

Thanks,

jeff

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Agree that the "use IE" option is only a workaround - when will Microsoft fix Edge to support OWA S/MIME?  Note that my Edge doesn't even support the Open in Internet Explorer option - it's greyed out.  Luckily I found IE using the info provided above.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

     I have had this issue also. I thought Microsoft would have learned from Windows 8 and WIndows ME, that they cannot roll out an operating system, or in this case a browser that does not fully support business. I work in government and S/MIME is mandatory in almost every email I send. *Hint/*Hint We have a lot of computers Microsoft! Late adoption has a lot to do with Microsoft's emphasis on "cool gadgets" instead of security in their software. I as a business end user should not have to deal with F12 and compatibility mode work arounds to conduct my daily business, especially with something as crucial as email (in this case OWA).  

     I hope some engineer from Microsoft reads this and takes heed, or we might start buying Apples. In fact that has already happened on the mobile front. Tick tock Microsoft...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Sorry for the delay in replying.

I would like to let you know that at present the feature you are looking for is not available. I recommend you to leave your findings, comments and feedback related to this product. Click on “More Actions” and click on “Send Feedback”.

Cheers.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same issue.  Love the response "It doesn't work, please comment on how you don't like this so we can ignore it."

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is currently the only hit on UserVoice for  S/MIME

https://windows.uservoice.com/forums/265757-windows-feature-suggestions/suggestions/6588313-add-s-mime-support-to-built-in-mail-app

Otherwise, if you can find it here, vote for what you want

https://windows.uservoice.com/forums/285214-microsoft-edge

 

FYI

Robert Aldwinckle
---

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I too am having this issue.  I have been racking my brain for days trying to figure out why my exchange team disabled the ability to install S/MIME.  After about a week of arguing with them, I tried Internet Explorer and VIOLA, the S/MIME install was available and works.  I agree with the other users, if Microsoft if focusing on business and government, then they may want to be sure that they FULLY support those markets.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.