Edge very slow to load pages

With a clean install of Windows 10, Edge is very slow to load a page.  IE11 works just fine, so does Chrome.  It is only Edge that is slow.

When I open Edge and go to any web site, it can take 20+ seconds to load.  Moving between pages on the site, loads just fine.  If I click on a link that takes me to a different site, its back to taking 20+ seconds to load.

I have tried the suggestions of clearing the history, running  Sfc and Dism and using a new local user account.  Nothing has made a difference.

Hi Jack,

Thank you for posting your query in Microsoft Community.

We would be glad to help you with the issue you are facing today. I understand the difficulty with the problem.

Method: 1

Clean boot

Check if the issue persists, in safe mode.


If the issue does not persist in safe mode, then perform a clean boot to from safe mode to check if any third party application is causing the issue, as clean boot helps in eliminating software conflicts.


How to troubleshoot problem by performing clean boot in Windows:

https://support.microsoft.com/en-us/kb/929135

Note: After you have finished clean boot, follow these steps to boot to normal startup.
a) Press the ‘Windows + R’ key on the keyboard.
b) In the ‘Run’ windows type ’MSCONFIG’ and click ‘Ok’.
c) On the ‘General’ tab, click the ‘Normal Startup’ option, and then click ‘OK’.
d) When you are prompted to restart the computer, click ‘Restart

 

Hope this helps in resolving the issue. If the issue persists, do get back to us. We will be happy to assist you.

Thank you.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

When I try to launch Edge in Safe Mode I get a message that Edge can'y be opened using the built-in Administrator account.
Jack Stockton
Microsoft Access MVP 2012 - 2017

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Jack,

Thank you for keeping us updated on this query. We apologize for the delay in response.

We will assist you in resolving your issue.

Before assisting  further, I would like to ask you few questions related to the query:

  1. Did you select Safe Mode with Networking option when entering Safe Mode?
  2. Have you enabled Built-in administrator user account? 

Method 1: Disable built-in administrator account by following the steps below and check if the issue is resolved.

  1. Open a CMD window by right clicking on the Start icon, and selecting Command prompt (Admin).
  2. Type the following command: net user administrator /active:no
  3. Lock the screen by pressing Windows logo key + L on the keyboard and check if the Built-in Administrator is disabled.

 

Method 2: If the issue persist, enable Safe mode with Networking option by following the steps from the link below and check if the issue is resolved.

 

Safe mode is a diagnostic mode that starts your computer with limited drivers necessary to run Windows. The words Safe Mode appear at the corners of your monitor to identify which Windows mode you are using.

 

Expand the options to boot into Safe Mode:

http://windows.microsoft.com/en-us/windows-10/troubleshoot-black-screen-problems

 

To exit from Safe mode follow the steps below:

  1.  Open Run command by pressing Windows key + R on the keyboard and type msconfig in the command box.
  2. Under Boot tab uncheck the Safe boot option.
  3. Reboot the system and check if the changes are effective.

 

To know more about Safe mode, following is an article on Windows Startup Settings (including safe mode) (Applies to Windows 10 also):

http://windows.microsoft.com/en-us/windows-8/windows-startup-settings-safe-mode

 

Hope this helps!

 

We are happy to assist you with any issues pertaining to Windows.

 

Thank you.

 

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That is all too much trouble. I don't want to convince my computer to work, I just want it to work. I went back to Google Chrome. It is easier.

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

hi have tried hundreds of things with this problem and found by downloading Microsoft ad blocker it completely got rid of the problem. 

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thank you for replying.

As the above methods didn’t resolve your issue, I would suggest you to Reset the Microsoft Edge and see if it helps.

Note: Resetting the Microsoft edge will remove your bookmarks and History.

a. Go to the following location.
C:\Users\%username%\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe
b. Delete everything in the folder. 
c. Now press Windows key and type Windows Powershell in search box.
d. Right click on Windows Powershell and select Run as administrator.
e. Copy and paste the following command.

Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" –Verbose}

Disclaimer: The Reset Edge Settings feature might reset security settings or privacy settings that you added to the list

of Trusted Sites. The Reset Edge Settings feature might also reset parental control settings. We recommend that you note these sites before you use the Reset Edge Settings feature. Resetting Edge isn't reversible, and all previous settings are lost after reset.

To back up favorites in the edge follow the steps below:

1. Open File Explorer, copy and paste the folder location below in the address bar, and press Enter. 
%LocalAppData%\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\AC\MicrosoftEdge\User\Default

    

2. Copy the Favorites folder to a place where you like to save your backup.

Hope this will help you. Keep us posted with the status of the issue. We’ll be glad to assist if you need further assistance.

Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Jack,

Thank you for posting your query in Microsoft Community.

We would be glad to help you with the issue you are facing today. I understand the difficulty with the problem.

Method: 1

Clean boot

Check if the issue persists, in safe mode.


If the issue does not persist in safe mode, then perform a clean boot to from safe mode to check if any third party application is causing the issue, as clean boot helps in eliminating software conflicts.


How to troubleshoot problem by performing clean boot in Windows:

https://support.microsoft.com/en-us/kb/929135

Note: After you have finished clean boot, follow these steps to boot to normal startup.
a) Press the ‘Windows + R’ key on the keyboard.
b) In the ‘Run’ windows type ’MSCONFIG’ and click ‘Ok’.
c) On the ‘General’ tab, click the ‘Normal Startup’ option, and then click ‘OK’.
d) When you are prompted to restart the computer, click ‘Restart

Hope this helps in resolving the issue. If the issue persists, do get back to us. We will be happy to assist you.

Thank you.

WIN10 doesn't let us get into msconfig - it pops up task manager and tells us to do what we need to do from there. Which we cant because task manager doesn't handle everything.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

THANKS!!!!!!! I reloaded W10 4 times last night to try and fix this and no luck each time. Of course NOTHING else worked till I tried adding Ad Blocker Plus, and ALL is good now....how rediculous though!!!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated September 24, 2020 Views 5,431 Applies to:

Related Forums