Disable Microsoft edge "always on top"

I want to disable "always on top", how do I do it?
 

Question Info


Last updated September 12, 2019 Views 20,405 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Peter,

 

Thank you for posting your query in Microsoft Community.

 

We are sorry to inform that you cannot disable Microsoft Edge.

Please share a few details to narrow down the issue:

  1. What exactly do you mean by “always on top?”

  2. What is the exact issue you are facing?

  3. Which browser are you using to access Microsoft Edge?

  4. Have you tried to access using other browsers?

 

Feel free to get back to us with the required information to assist you further. We will be happy to help.

 

Regards,

Jenith

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I can't be sure what PeterSawrie is referring to, but I have a similar problem.  The issue is exactly what he stated:  IE Edge seems to always be "on top" of other windows.  In technical terms, it looks like the Z-order of the window forces it to show above any other windows, even when it's not the active window.  By active window, I mean the window selected with the cursor that is accepting keyboard input.  By Keyboard input I mean the typey thing with the buttons on it you poke at to create messages to explain what "always on top" means. 

As an example, I'm typing this in the Microsoft Edge browser which appears "on top" of all the other windows.  Opening Microsoft IE 11 causes the window for IE 11 to open UNDER the Edge browser window.  There doesn't appear to be a setting when you click on the ellipses button in the upper right corner of the Edge browser (ellipses are the three dots.)  How do we cause the Microsoft Edge browser to behave properly when it comes to Z-Order?  Is there a setting somewhere?

124 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Jenith_James,

Do you have an answer to the point shown above, since I'm suffering of the same disease...

  1. What exactly do you mean by “always on top?”
    It means that if I have several windows opened in the same screen, Microsoft Edge will always appear "On Top", and no matter how many times you click the other windows, they will never come on top. The only way to see it is by minimizing the Edge window.
  2. What is the exact issue you are facing?
    The same as explained in Point 1.

  3. Which browser are you using to access Microsoft Edge?
    Explorer Edge. Is not Edge a browser itself. I apologize for my ignorance.

  4. Have you tried to access using other browsers?
    The matter is not the browser, but the window itself. You can have explorer opened checking a folder in your documents, this will never come up over the Edge window, no matter how many times you click on it. It seems to me that it is a Windows issue and not the explorer, or it is Edge itself. I check the setting inside Edge and not even in Advance there is a setting that can make this possible.

HELP PLEASE... IT IS MOSTLY ANNOYING, AND I LOST ONE MONITOR, BECAUSE IT IS ONLY RESERVED FOR EDGE, WHICH IT DOESN'T MAKE SENSE.

20 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Jenith_James,

Do you have an answer to the point shown above, since I'm suffering of the same disease...

  1. What exactly do you mean by “always on top?”
    It means that if I have several windows opened in the same screen, Microsoft Edge will always appear "On Top", and no matter how many times you click the other windows, they will never come on top. The only way to see it is by minimizing the Edge window.

This sounds like you've got the "tablet mode" turned on...

https://support.microsoft.com/en-us/help/17210/windows-10-use-your-pc-like-a-tablet

32 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Mr Graye,

Thanks for the quick response but I do not think that is the reason. The option for "Table mode" appears in grey, so it is not active. Actually I can't activate o deactivate this option at all. It is there just in grey not available.

Any other option? This happened after the last upgrade on Windows. Please find two pics attached below. One showing the "Tablet mode", and the second one showing how it looks a snapshot of a Folder Explorer windows, with the superposed Edge window using google maps. The Explorer Folder was selected, but it never gets on top of the Edge window.

Regards,

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah, but that still doesn't make any sense to me...

I typically have several windows up at the same time, and I *never* have had an issue with the "z-order" of Edge.

So, I'm wondering if this is a one-off thing that's just happening to you (and perhaps a few others).  Have you installed anything strange lately?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It doesn't make any sense to me either because I haven't experiene this at all, but it is happening. Something happened with either the last update or with Edge itself. And just so you know I have not installed lately no software that can cause Edge to superpose on top of everything. I tried several application to see if there was one with higher hierarchy than EDGE and nothing (Office all of the packages: Excel, Powerpoint, Word, Publisher, Office, etc.), Adobe Acrobat, Explorer itself, Internet Explorer 11, Notepad,  Mozilla, Chrome, etc). All of them end below Edge.

That is why I'm contacting Microsoft forum... You guys should know something... Really help...

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Please find the examples showing how it is always on top of the "z-order" no matter what is selected. I used for the example Mozilla, Chrome, and Calculator, and always as the shining star is on top Edge... Frustrating...

Calculator selected as it can be seen by looking Chrome and Mozilla:

Chrome selected as it can be seen by looking Mozilla and Calculator:

Mozilla selected as it can be seen by looking Chrome and Calculator:

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Very bizarre, indeed...  

Sorry, I don't have any suggestions (other than perhaps a reload of Edge?).

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had the same issue as the OP, my edge web browser also stayed on top of other windows, clicking other windows or alt-tabbing to other windows didn't make them come forward. Thsi was since the latest windows 10 updates. When I saw your post, I noticed my laptop was not on tablet mode, but after turning this feature on and off, edge didn't stick on top of other windows anymore. So thanks for pushing me in the right direction!

175 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.